Plugable USB 2.0 Ethernet adapter not working


#1

Have installed drivers, drivers up to date, adapter shows up in my device manager with no issues. In network connections I keep getting the message ‘network cable unplugged’, with a flash of green and orange lights, every 20 seconds or so. Then after 5 minutes or so, it looks like there is activity in my router and the adapter, all lights flashing as if data is being transferred, in network connections I have ‘unidentified network’ and ‘limited connectivity’. Then back to ‘network cable unplugged’. Have tried 3 different network cables that all worked yesterday, so doubt that’s a problem. Windows Vista Home Premium 32bit


#2

Hi Conan,

Thanks for contacting us, we’ll be able to help. The first thing I’d like to have you try is to power cycle the router with the ethernet adapater plugged in.

If that doesn’t help, login to the router and verify that DHCP is turned on. If you can say a bit more about the make and model of router you have I’ll be able to give you some more specific advise on how to configure it.

Also, if possible try a different computer on the same wired connection. If it’s able to get an address and connectivity automatically, we’ll be more confident that there’s something going wrong with your Plugable adapter or it’s setup.

Let me know what you find,
Thanks,
Jerome.


#3

Solved, DHCP was off. Thanks Jerome


#4

Glad to hear you are up and running, and thank for letting us know.

Jerome.


#5