Plugable UGA-2K-A USB to VGA/DVI/HDMI Adapter - SKYPE for Business update w/Win 8.1- adapter driver v 7 does not work


#1

Plugable UGA-2K-A USB to VGA/DVI/HDMI Adapter SKYPE for Business update with Windows 8.1 - adapter driver version 7 does not work - I need to re-install driver version 7.6.56265.0 - How do I obtain and re-install older driver?


#2

Please see -> http://support.plugable.com/plugable/…


#3

These are two separate issues with two separate computers (each computer using three Plugable Display Adapters).
Work computer - I have gone to the http://support.plugable.com/plugable/… web site for drivers - and only saw where I could download the latest drivers (version 7) for Windows 8.1 - After Microsoft updates this week with SKYPE for Business these drivers do not work. I need to revert/re-install the older Plugable Display Drivers 7.6.56265.0
Kindly advise where I can find this driver and re-install them.


#4

Hello Eileen,

In this case you can take a look at DisplayLink’s own archive -> http://www.displaylink.com/downloads/… for earlier versions. If this particular Skype happens to work only with DisplayLink’s driver version 7.6.56265.0, would you please be so kind as to pass on the exact version number of Skype?

Kind regards,
Patric
Plugable Technologies


#5

currently I am having difficulty getting the computer to go back to the 7.6… Display Adapter driver.

Even though I am uninstalling and checking the box to delete the file, then attempting to re-install with the 7.6 - I get the response that it is already up to date (with v7.7) and thus it still does not work. :frowning: – So … how do I completely get rid of 7.7?

I am confident if I can get back to the 7.6 drivers everything will work good together as another co-worker has the same hardware setup and their SKYPE updates work wonderfully but they are using the 7.6 display adapter drivers whereas I had the v7.7

SKYPE for Business 2015 (15.0.4737.1002) 32-bit


#6

Hi Eileen,

After deinstalling the DisplayLink driver, download and run the DisplayLink cleaner tool -> http://displaylink.com/support/sla.ph… and reboot. This will give you a clean slate to work with.

Kind regards,
Patric
Plugable Technologies


#7

Thank you for the Display Link Clean up link - I was able to revert back to the older drivers, however, unfortunately it still will not work with Skype for Business :frowning:


#8

Hello Eileen,

Please try the newest driver version 7.8 ->http://www.displaylink.com/downloads/… via a clean installation (use the cleaner once again). If we end up with the same symptoms you would need to open a thread on the DisplayLink forum -> http://displaylink.org/forum/ mentioning the exact Skype version number where this conflict is happening. They can help you further or maybe they know of a workaround/trick.

Kind regards,
Patric
Plugable Technologies


#9

Update: Yes the newest driver version 7.8 via a clean installation resolved the issue. KEY Point as well is to remove all connections to the computer and bring up SKYPE for Business – SKYPE for Business 2015 (15.0.4737.1002) 32-bit – AFTER drivers were updated. Then plug in the USB to the Display Link Adapter/s.

Thank you Patric!


#10

Hi Eileen,

You are welcome. Good to hear you are back up and running again and thanks for posting this. Other customers will be able to reference this thread if they have this issue in the future.

Kind regards,
Patric
Plugable Technologies


#11