Plugable ud-3900 does not correctly connect to monitor


#1

I have a VGA monitor connected to my plugable via the DVI converter (that came with the product). I connected it to a brand new Windows 10 laptop. For a second, the monitor screen came to life, mirroring the laptop screen, but then the monitor screen froze and went “fuzzy” with a static image.

My screen on my Dell laptop (Ultra-definition touch screen) is still working fine. But the monitor is still frozen.

I have been through your suggested fix here:
http://support.plugable.com/plugable/…
I have “uninstalled”, “cleaned” and reinstalled the drivers.

When I connected the plugable back up, it did not “continue the installation” (that I could see) - I didn’t get a “skip” dialogue.

However, the USB ports are working.

It is just the monitor that doesn’t work, and that’s the main reason I bought the plugable. Can you help?


#2

Hi Tara,

Thank you for posting! I am sorry your docking station is not working as expected and I would be happy to help.

Thank you as well for the detail you provided and the troubleshooting you have already performed that is much appreciated. The behavior you describe is certainly not typical nor is it expected, so our next step is to get some additional information.

If you would, please keep everything connected (even though the monitor connected to the dock is not working) and send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to support@plugable.com with ‘For Ticket # 231989’ in the subject line. This will allow us to match things up and examine some log files from your system to help determine the next steps.

* Please also include your Amazon Order ID number for the docking station purchase in your direct email (please do not post either the Order ID or PlugDebug in our public forum). *

Thank you for giving us the chance to help!

Bob
Plugable Technologies
www.plugable.com/support


#3

Thanks Bob. I have done this and emailed you with the debug file.