Plugable Docking station no longer recognized


#1

I bought my Plugable USB 2.0 Universal Laptop Docking station with displayLink DVI/VGA from Amazon 3 months ago. But suddenly when I plug in my laptop none of the devices (monitor, external drive, keyboard/mouse) are recognized. The light still is on for the Plugable device but the computer cannot detect that it is connected to it. I have tried restarting my computer and unplugging and re-plugging in the Plugable device. Also, I have tried other USB ports on my laptop. Can you offer any trouble shooting advice?


#2

Update. When the Plugable device is plugged into my bosses laptop it is not recognized either.


#3

Hi Ryan,

Sorry for the frustration! Two machines makes it a likely hardware problem. We’ll be able to confirm that quickly and get you back up and running.

Just email your Amazon order # to support@plugable.com and a link to this thread, and we’ll take care of you.

Thanks for your patience!
Bernie


#4

I also have a similar issue. One minute the device wass working properly (after several weeks) and the next minute a message that the device has malfunction and Windows 7 no longer recognizes the driver. I uninstalled the driver, re-booted the machine and still the same issue.

lkrich@loats.org


#5

Hi lkrich - It’s not clear whether that’s a hardware or software issue. Could you grab the DisplayLink Logs (here’s now: http://plugable.com/support/displayli…) and email the resulting .zip file it generates on your desktop to support@plugable.com – we’ll be able to figure out next steps from that.

Thanks!
Bernie


#6