Photoshop Elements 19 (PSE) "Places" will not load


#1

I just purchased the UD-ULTC4K docking station and everything is working very well, except one problem. I cannot load the “places” map (which is mapbox?), through PSE, unless I am disconnected from the docking station OR my internal display is the main display. I have 2 external monitors and prefer one of them to be my main display most of the time, so is there a better way to load the PSE maps without changing my main display settings?


#2

Hello, thanks for posting and I will be happy to help.

Thanks for the description of the behavior. If you open Photoshop Elements first on your internal laptop monitor and then drag it over to one of the monitors connected to our dock does the map on the Places tab seem to appear?

Some graphics applications like Photoshop Elements rely on OpenGL graphics standards. In some instances, Windows mistakenly directs the OpenGL tasks intended for your internal graphics adapter (which does support OpenGL) to the Plugable docking station (that does not support OpenGL). Our docking station is not a traditional physical graphics adapter in and of itself. It is a ‘virtual’ graphics adapter that relies on the host system’s CPU and the internal physical graphics adapter to work. If this misdirection occurs, it can result in similar behaviors as you describe. Sometimes there are settings that can be adjusted within these applications to ‘Disable hardware acceleration’ but I am unable to find such a setting browsing the Photoshop Elements settings or searching on Adobe support forums.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#3

Hi and thanks for the quick response!
I am able to drag the program over to the external monitors and it will still work. It is just an inconvenience at this point and was hoping for a work-around, as I prefer that my external monitors are the main display.


#4

Thanks for the reply and understood the inconvenience. I am able to replicate this with our products but I cannot find an applicable setting that could help workaround this issue.

Other than dragging the window over to the desired monitor once opened on the internal display another workaround that can be tried is to connect the desired main display to the “HDMI 4K” port as I presume that the monitors are currently connected to the two DispalyPort ports on our UD-ULTC4K?

This would depend on the available input ports on the monitor, but if the monitors have an HDMI input port you can use an HDMI cable to connect the devices. The “HDMI 4K” port on the UD-ULTC4K dock is not based off of DisplayLink and provides a direct pipeline to the internal graphics adapter.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#5

Thanks! I was worried before I realized it was a minor inconvenience. The Photoshop Support - they have no idea why places won’t load, so they have no idea how to fix others with the same problem.


#6

Thanks for the update and sorry to hear that Adobe Photoshop support also does not have a solution. It certainly seems like this is an OpenGL incompatibility with our dock and the Photoshop Elements application and I apologize that I cannot be of more help.