PC won't boot with I/O card plugged in!


#1

I just tried to install your USB 3.0 I/O card. I seated it in the motherboard, and attached power. However, as soon as I tried to turn on the computer, it would not power on (not even to CMOS). Computer went back to working normally as soon as I removed the card. What’s going on?

Thanks!


#2

Hi Dan,

That’s very unusual. What make and model of PC do you have? Can you try connecting the card again without the power connection? It will work fine without it, and it sounds like your power supply wasn’t happy (and not turning on) for some reason. Also, make sure that the card is fully seated in the slot and that the slot is a 1x PCI-Express slot. You may need to remove the face plate from the card, there’s a small one included in the box if you find that this helps.

Let me know what you find,
Happy Holidays!!!

Jerome.
Plugable Technologies


#3

Hi Jerome! It’s an HP Pavilion e9280t. I tried it both with and without power connected. In both cases, power came on for a split second, fan spun up and immediately spun back down, and it wouldn’t even boot to CMOS. As soon as I removed the card, everything went back to normal. I tried seating the card several times, so I don’t think that’s the problem.

Any ideas?

Thanks!


#4

Hi Dan,

Thanks for taking those troubleshooting steps. We’ll test a card here and send it out to you, that way it will either work or we’ll know there’s some other problem either with compatibility or with the motherboard. Can you reply to support@plugable.com with your Amazon order Id, the best shipping address to send a replacement to and the serial number of the card you have now? Also, in the meantime, can you verify that the card is plugged into a 1x pci-express slot. I see from the documentation for your HP Pavilion e9280t there are a number of PCI-Express slots, but only one of them is a 1X. You’ll want to make sure to use the 1X slot as the card may fit into the others but it will not function correctly.

Thanks for your patience,
We’re here to help,
Jerome.


#5