No video, device doesn't seem to work

This is frustrating because the device doesn’t seem to work at all.
To be clear, I followed the steps listed on the website verbatim, and while I’m at it I tried the following:

two different PS3’s
an XBox
Three different TV’s
Four different HDMI cables
Both Mac AND Windows OS
Two different software applications listed under the steps
fiddling around with the software applications settings
switching around the HDMI ports for fun

but nothing I do gets me any video at all, anywhere. I get absolutely no video no input at all. Just a blank black screen. How does anyone get any video to display anywhere? What does one do to get this thing to work? It doesn’t do a thing for me except illuminate.

I had the same issue, but am a Mac user. As you plug in the Microscope and launch the software, Mac asked me if I wanted to give access to the main camera which I responded with a ‘No’. Well, in that case the microscope doesn’t work either. So I went into ‘Security & privacy’ settings and gave access, restarted the software and all seems to work fine now.

@CheesyNut — Thank you for helping to assist here. From other communication that we currently have open with @sailor, this is not related to the microscope but rather to the Plugable HDMI capture card.

@sailor — Thank you for your messages both here and via email to our support.

Please note that we mainly provide support during our typical office hours, which is usually between 9AM and 5PM Pacific time. I understand you’ve been doing a lot of troubleshooting, that you’d like this resolved, and that this experience is frustrating. Any patience you can afford until we can help resolve this is appreciated. I will continue to follow up with you via e-mail, but that may need to wait until Monday.

Thank you.

I’ve got a lot of experience dealing with various hardware and software, but as these gaming consoles are all proprietary; and HDMI is poo-pooed in the networking and software engineering computer world for reasons I don’t understand. So I’m unfortunately lost if it isn’t a Mac, Windows, Linux or network issue where I can actually get into the hardware/software code and tweak things.

And in this case, for whatever reason I receive no video and if I’m the first person to have this problem then hopefully when an answer is reached anyone in the future who gets the same lack of response from the piece of hardware will be able to quickly find an answer.

@sailor I sent another email over the weekend regarding the issues you’ve described.

As noted there, the PlayStation 3 will have HDCP copy protection at all times by default, and the NIX Capture Card does not support capturing from HDCP sources.

This is also the case with the Xbox 360.

Newer console platforms like the Xbox One, PlayStation 4, and Nintendo Switch are capable of outputting gameplay via HDMI without HDCP enforcement enabled.

The best bet for testing is to try and capture a stream from the Mac or the PC (with the USB data being sent to the opposite computer). Mac and PC systems will only enforce HDCP if copy protected content is being displayed on screen, so as long as you’re just on the desktop and not playing copy protected music, the capture process should work in that scenario.

Please feel free to follow up in our support email thread. Thanks!

I did some research on this topic you brought up, and I bought a
device that is supposed to redirect or get around that HDCP, but I
still get no video at all. I can clearly see video on the TV even
with the bi-directional video switch, but if I plug that nix device
between the streams so to speak, then I get nothing at all.

I’ve tried doing things from my computer and again, I just get a black
screen. No desktop video, nothing at all. For some reason, no matter
what I do, or use, I just get a black screen.


I have a Component to HDMI converter that I had bought for the Wii years ago and even tried using THAT to go PS3 component cable to the Component to HDMI converter box TO the Nix box, and still get nothing. I get nothing going from my Mac HDMI out to the Nix either; and no iTunes playing just normal desktop nothing going on.

Since a device that removes HDCP would alter the video signal in some fashion and could modify other information such as the EDID information, it is best to test using a known-good source like the Mac or PC.

I will send a follow up in the email thread you have open with us to gather some more details.

Alright, so even having and using a video switcher that removes the HDCP is still not good enough, I went back to the 1990’s technology before HD and HDMI was even a thing and tried using a Sega Saturn with different video options, the regular composite cable to HDMI, the SCART to HDMI, and none of these things do anything.

The situation remains the same, no matter what I do, I get just a black screen and no video from any source from apparently any decade.

@sailor To state publicly what I mentioned in my most recent email exchange with you, the Sega Saturn outputs analog signals that must be converted to a digital signal through a process called scan conversion.

Depending on the scan converter, and how rigidly it conforms to the input analog signal it receives from a console when generating the digital HDMI output, it can produce resolutions that are not supported by the NIX capture card.

This is particularly true of the Sega Saturn, which generates a variety of oddball resolutions.

When troubleshooting the capture card, it is best to use a current-generation game console that has known functionality to omit HDCP protection from video signals, or the video output of a PC/Mac, which output standardized HD resolutions.

Don’t have current consoles, and I got nothing out of the Mac which is also my PC via virtual machine. I know my luck with these things is terrible but I am amazed anyone can get these things to work since everything is a technically unable to actually work because of various reasons. I’m guessing the Wii also outputs a crazy oddball resolution when converted to a digital signal, since it too didn’t output any video.

@sailor Thank you for your replies. Please provide the PlugDebug log requested in our email thread so that I can help investigate.

Just in case it helps anyone else, so far the next step in investigating has been to look at the logs created by the OBS application. This is absolutely a good idea and exactly what I would do were I on the other end.

After having them reviewed, I was advised to set it up IAW the instructions as created here “

I had done that the first time before ever looking for help. Apparently another or separate problem is that this application doesn’t want to recognize any video coming in, only audio. I already tried re-doing the steps after doing a uninstall of the application and then re-installing it just so there was a clean slate and nothing changes.

What a troublesome and complex situation

So I sent the log data, and the support team still has no clue what is wrong. I used a Nintendo Switch, and that device is specifically listed as having no HDCP and no problems whatsoever doing video for this piece of hardware. Neither apparently does the Mac or Windows, yet neither of them show video; the Switch didn’t either.

I was given a pdf to print that has a return shipping label, and I mailed it out as I was instructed since the support team believe it could be a faulty unit. Haven’t heard anything since, and I e-mailed them yesterday looking to see if they finally got the unit since I mailed it on the 8th of October this year. Haven’t heard anything back, and I contacted Amazon where I purchased this and they say they haven’t heard from the company either.

Initially the support team was pretty good about getting back to me with things to try to get this to work, but as each and every step has failed, now I’ve sent it back looking to get a refund.

For those interested, I would like to share our side of this support experience as well.

As you may see from the rest of this thread, this customer has been introducing additional variables that complicate the support process, rather than following explicit guidance and direction for us to help resolve this in a more expeditious fashion.

Regarding the customer’s claim that they emailed us yesterday for an update regarding their return of the capture card. This is accurate, we do have this communication but a reply was not sent yet.

Our default return/replacement shipping method is via a USPS business reply by mail label that we provide at no cost. However, this method of shipping is quite slow, and does not include tracking information. So for more expeditious returns, as well as better verification of when products are received by us, we recommend using other shipping methods (which was recommended to this user).

Additionally, we did not offer to provide a refund at this point. The return label was given for the customer to get a tested and verified functioning replacement under warranty, since they have had the capture card for over six months and have only now started raising concerns about the capture card.

To better understand the timeline, if my name handle didn’t indicate it, I’m a service member and in my profession we have to pack a lot of stuff in a small amount of space. The reason it took so long to test the capture card was from my misplacing it on myself. I thought it gone and that would be on me for losing it. When I found it hidden away with other not often used items like the uniforms that are only worn about half the year, I went to test the device. I followed all of the steps from the website which lead me here. I have worked with the support and send the data as requested. If the device truly worked in the manner described then the Nintendo Switch should have been the moment of truth.

The device is in pristine condition, that will be evident and I don’t understand why this device doesn’t work but it doesn’t for me. Maybe it’s my computer but I’m not running any version listed as incompatible or experiences difficulty. I don’t know what other steps are needed to tweak this thing into working, supposedly if you plug in the switch to it’s dock and do HDMI out then you’d see video in the app. I only get audio from the software picking up my computer’s microphone.

It’s a black screen no matter what happens. I’m sure the thinking is that I purposely broke it and am trying to pull one over. The only trick is getting this thing to function as advertised. Nobody has been able to provide instructions that work. It doesn’t do any good for me, so I happily sent it back with their label that has no tracking. I thought I was doing good by this, following instructions. In the future it’s best for everyone who needs to send something back to do it with a tracking number so all concerned can keep up with the status.

I’d be interested to see how anyone else gets this to work and by what means. It doesn’t seem to be compatible with anything I own, Switch, Mac, or PC. I can’t say for sure if there is something about my OS versions or other apps that could be interfering because I simply don’t know enough about this device and the third party software.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.