No green lite, worked once and died!


#1

just got my usb 2.0 UGA. Downloaded drivers , installed on my windows7/32 machine. Worked once. Now I have no green light on the uga. Device manager shows installed, working properly, drivers up to date but obviously without a green light the monitor has no signal. Tried using HDMI, all other USB ports, another monitor, another usb cable, even another pc… it is definitely the plugable. Are these things that sensitive? I had high hopes this would work better than Tritton but I am bummed. HELP!!!


#2

to add information to this after reading other posts, in Device Mgr I show a USB Display Adapter ( no errors) , shows as working properly, driver 5.6.31854.0, details Value is DisplayLink Display Adapter (8060). I am using Windows7/32 on a Lenovo T410s, monitor is (pick one) Acer H243H and H233H. When I plug in the uga, Windows recognizes a usb device is plugged in and shows ready to use. Task Mgr shows DisplayLinkManager and DisplayLinkUserAgent running for processes.


#3

Hi Laja!

Thanks for posting! Sorry to hear you’ve had trouble with our USB 2.0 UGA!

Sounds like a bad unit! Please e-mail us at support@plugable.com and include the following:

a) your Amazon Order ID
b) the Serial Number of the device (to be found under the device on a sticker)
c) your current valid address

and we’ll have a replacement out to you as soon as possible!

Again sorry you’ve hit this problem!

Regards,
Lampros


#4