No connection after installing USB2-E1000


#1

I’ve installed a USB2-E1000 adapter after loading drivers. Adapter appears correctly in device manager. But now I have no internet access. There are no lights on the E1000. If I reconnect to my old USB 2 10/100 adapter, I have a connection.

The original built-in adapter no longer works, and I have disabled it.

Any ideas how to get the E1000 to work?

Thanks,

George


#2

Hi George:

Thanks for posting with your findings!

Typically, if we’re seeing the ASIX 88178 device under network connections in the Windows Device manager, (and there is no yellow exclamation mark there showing a driver problem) but you’re still not getting activity lights, there’s some issue with the upstream network. Since you’ve already tested against this possibility with another adapter, two possibilities come to mind:

  1. In some highly secured networks only devices with a known MAC address will be offered a DHCP address. Are you able to share any details about the network you’re connecting to such as whether this at home or at an office?

  2. If this were a defective device, I’d not expect to see it in device manager, although it’s still possible. If it’s convenient to try testing the adapter on another system to verify if the USB2-E1000 is able to pull an IP and get online normally that could also help us isolate a potential defective device.

Again, thanks for posting and best wishes.

Sincerely-

Jeff Everett
MCITP Enterprise Support Tech
Plugable Technologies


#3

Jeff,

Thanks for your prompt reply.

The E1000 adapter shows up correctly on the device manager as if it’s working properly. If I go to the Control Panel/Network and Internet/Network Connections window, the E1000 connection says Network cable unplugged. I tried switching cables, but I got the same result.

I’m using the E1000 on my home network. The adapter is plugged into a Siemens Speedstream 4100 from AT&T to access the internet.

The adapter that does work is a D-Link DUB-E100.

I’ll work on finding another PC I can use to test the adapter.

George


#4

Hi George-

Thanks for the details and efforts using another system to double check the adapter.

I’m thinking defective device is a good possibility but I’d like to verify if possible before trying an exchange without knowing if it will help. If this were a gigabit vs megabit problem it would be very surprising, I’ve never seen that, gigabit adapter should just work at megabit speed. That said, thanks for sharing the detail that the D-Link worked on the same connection, that was part of the reason I’m thinking you might have received a defective.

Please let me know if you’re able to find an alternate system to test with and we’ll go from there. If it doesn’t work on a second system we’ll try a pre-tested replacement.

Best wishes-

Jeff Everett
MCITP Enterprise Support Technician
Plugable Technologies


#5

Hi Jeff,

I tried the E1000 on my sister-in-law’s computer. She has a simple internet setup similar to mine. On her system, the E1000 makes a connection and displays blinking lights. Now I’m really stumped. There must be some setting on my machine that is preventing a connection with the E1000. Any ideas?

George


#6

Hi George,

I’m glad to hear you didn’t get a faulty unit, hopefully we can get it working on your network as well with a little more troubleshooting.

My best guess at this point is that I’ve seen for some odd reason systems needing an extra reboot or unplug/replug of the adapter.

I’d recommend trying a reboot or two and playing with unplug replug. I’m not at all against offering an exchange but I think there’s something system/software level at issue.

Please let me know if this helps or if you’ve any other questions.

Best

Jeff


#7

Also, this isn’t as likely since the device shows in device manager already, but trying different USB ports might be a good idea, as well as different ethernet cables if we’ve not already checked that.

JE


#8

Hi Jeff,

Even though this E1000 works on another machine, I’m beginning to think it won’t work on mine.

I’ve tried other USB ports, and I changed the CAT 5 cable I was using to a CAT 6 cable, but with no success. When I use the E1000, my computer tells me I need an ethernet cable connection.

Here’s what I’ve also tried:

I enabled the existing built-in gigabit adapter. The built-in adapter shows up fine in diagnostics, but it won’t pass data or if it does, it’s agonizingly slow. I originally replaced it with a 10/100 adapter, but wanted to get back the original performance of the gigabit adapter. When I hook up the original adapter, my network view on the Network and Sharing window shows a good connection. I can’t do anything with it, but the computer thinks it’s a good connection.

I insert my D-Link 10/100 adapter into a USB port.

I insert the E1000 into a USB port.

I can unplug the ethernet cable from the built-in adapter and plug it into the D-Link 10/100 and the system recognizes the connection immediately.

When I unplug the ethernet cable from the D-Link 10/100 and plug it into the E1000, I have no connection.

I can unplug the ethernet cable from the E1000 and plug it back into either the built-in adapter or the D-Link 10/100 and I have a connection again.

I’ve tried switching USB ports on the E1000 and D-Link adapters at this point, but it makes no difference.

I’ve tried rebooting at various points, and it makes no difference. I’ve tried disabling the built-in adapter on a reboot, and it makes no difference.

Any ideas?

George


#9

Hi George-

This is an odd one! Thanks for your patience working through this. We’ll get you up and running one way or another!

That said, I’m not sure an exchange will help, so I’d like to try a couple last ideas before we go that route. If you’re fed up with troubleshooting and want to try an exchange let us know, but knowing the thing worked normally on your sister’s PC makes me hesitant to go that route.

My next idea is simply to re-install very thoroughly and carefully, just in case the driver didn’t install correctly, let’s try completely uninstalling the ASIX 88178 driver from device manager.

Here is a detailed walk-through from Microsoft. In particular, you’ll want to follow this section on how to
_"Reinstall a Plug and Play device

Reinstall a device only if it is working improperly or it has stopped working altogether. Before you reinstall a device, try to restart your computer and check the device to determine whether it is functioning properly. If it is not, try reinstalling the device.

To reinstall a Plug and Play device
Open Device Manager.

Follow the instructions in the preceding procedure to uninstall the device.

If you are prompted to restart the computer, follow these steps:

Plug in the device and then restart the computer. The device will be detected and reinstalled after Windows restarts.

Follow any instructions on-screen to complete installation.

If you are not prompted to restart the computer, follow these steps:

In Device Manager, in the Action menu, click Scan for hardware changes.

Follow the instructions on the screen.

Note
Scan for hardware changes will not reinstall a Plug and Play device if a driver is already installed on the computer. If the device has not been uninstalled, Scan for hardware changes will not detect the connection of the device as a change. You must uninstall a Plug and Play device for Windows to start an installation when you connect the device again._

If the above isn’t helpful, can you please email the following to support@plugable.com with a link to this thread, attention Jeff?

  1. Amazon order ID
  2. Serial number from your device.
  3. Shipping address.

Best wishes-

Jeff


#10

Hi Jeff,

Thanks for your last suggestion. I did the complete uninstall. Then installed again. The E1000 worked immediately. I checked the speed on the Network and Sharing/connection window and it was 1 Gbps. Success!

Just for the record, over the weekend I installed a router in preparation for future upgrades to my home network. So when I installed the E1000 this time, my connection wasn’t the same as when I first reported the problem (I tried the E1000 with the router, but the router kept telling me I didn’t have the ethernet cable attached). In any case, now I’m a satisfied customer.

Thanks for taking the time to work through this with me. I really appreciate your efforts to resolve this stubborn problem. I wouldn’t have considered the complete re-install since there was nothing to indicate a driver problem (other than the device didn’t work). Kudo’s to you for suggesting it.

Thanks, again.

George


#11

Awesome, glad to hear you’re up and running George!

Please let us know if we can assist in the future.

Best wishes-

JE


#12

Hi Jeff,

Just to follow up and offer a summary of what happened:

My problems started when I inadvertantly enabled a second network adapter. I assumed I could have multiple adapters hooked up as long as just one was connected to a network. While I was trying to resolve the problem, I had up to three adapters enabled. When I finally resolved the problem using the uninstall and re-install, I had disabled the built-in adapter using the boot setup screen and the only network adapter on the system was the E1000. My suspicion is that the E1000 driver got hosed when I enabled another adapter (loaded another adapter’s driver).

Again, thanks for your help.

George


#13

Hi Jeff,

Here’s some more follow-up on this problem.

I lost my internet connection a few days ago. That gave me a chance to test various hookups again. Here are the results:

I could not get the E1000 to work when I attached it from the computer directly to the modem. However, the D-Link 10/100 adapter would work.

When I attached the E1000 to a Linksys E3200 router (modem plugged into router), the E1000 works!

So the E1000 will work on my computer, but only if I use a router.

George


#14

Hi George-

Some ISP’s only allow a single MAC address (sort of like a serial number that’s unique to each network interface device, wired or wireless, that uses TCP/IP) to be connected to your modem. In these cases I’ve typically seen the modem will grant an IP address to the first device only, so could be a reason for the behavior you saw. Routers use a variety of tricks to avoid this limitation, so this isn’t unusual.

All that said, each network is somewhat unique so I can’t be sure but thought I’d offer at least a potential explanation.

I’m glad to hear you’re up and running :slight_smile:

Best-

Jeff


#15

Hi Jeff,

After several months of problems with all kinds of adapters, the real problem finally surfaced. My modem finally died and after I replaced the modem, all adapters (including the E1000) worked perfectly. Even my original built-in gigabit adapter works again. Apparently, modems can be tricky to troubleshoot unless you have a replacement modem. Thanks for your help in trying to resolve this.


#16