Monitors quit receiving signal from dockingstation

I have two monitors (Dell 1909W) connected to the docking station (USB 3.0) along with a mouse and keyboard. I have a Dell latitude 7320 running Windows 10. Everything worked fine for about 3 months and all of a sudden the screen on one monitor quit quit working although the screen saver was still showing. I can’t tell if the other monitor isn’t working or not. I have unhooked everything and re connected it with no success. Can you suggest anything.

Thank you,
Jon

Hi Jon,

Thank you for contacting Plugable! Sorry to hear of these issues, but we’ll be happy to help investigate and find a solution.

When you have a moment, could you please let us know the following details:

  • The model of your Plugable device (located on the product itself, the box, and the quick start guide)

Thank you for your patience and for giving us the chance to help!

Richard A
Plugable Technologies
https://plugable.com/support

It looks like the model is ud-3900. The serial # is T20-00128888. I Have lost the quick start guide so if there is one on the website please let me know where it is.

Thank you very much.
Jon

Hi Jon,

Thanks for the update.

Here is a link to the Quick Install Guide for the UD-3900:
https://s3.amazonaws.com/plugable/doc/2018-04-26_Plugable_UD-3900_QSG.pdf

The first steps we’ll want to take is to make sure that the software used by the dock is in a good state by reinstalling the DisplayLink software and running the DisplayLink cleaner tool. To do so, please follow these steps:

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely (this is important so the unit resets). Please keep it disconnected until the last step.
  2. Uninstall any and all software with ‘DisplayLink’ in the title that is present from within the Control PanelPrograms and Features. Don’t worry if these entries are not present or if the process does not work, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool (https://www.synaptics.com/products/displaylink-graphics/downloads/windows-installation-cleaner)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 10.1 M2 DisplayLink software (https://www.displaylink.com/downloads/windows)
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system which will trigger the final portion of the installation

Hopefully that will get things working for you.

Thank you for giving us a chance to help!

Richard A
Plugable Technologies
https://plugable.com/support

Richard,

Your recommendation worked perfectly. I can’t tell you how happy it makes me feel to be able to use my monitors again. I really appreciate the fact that you monitor this forum and give suggestions on how to fix problems like mine. Thank you very much!

Jon,

Thanks for the update and I am so glad this is working.

Richard A
Plugable Technologies
https://plugable.com/support

Richard,

Richard,

One of my monitors has quit working with the docking station. I rebooted everything and it didn’t help. Do you have any suggestions.

Thank you,
Jon

Hi Jon,

Thank you for posting! I am sorry your docking station is not working as expected and I would be happy to help.

Thank you as well for the detail you provided and the testing you have performed that is much appreciated. Based on your description of the behavior, our next step is to get some additional information.

Please keep the dock connected to your system (even though not working) and send the output of our diagnostic utility PlugDebug → http://plugable.com/support/plugdebug to us directly via support@plugable.com with ‘For Ticket 368923’ in the subject line. This will allow us match things up and examine some log files from your system to help determine the next steps.

Please also include your Amazon Order ID number for the docking station purchase in your direct email. Please do not post the Order ID or the PlugDebug file in our public forum.

Thank you for giving us the chance to help!

Richard A
Plugable Technologies
https://plugable.com/support

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.