Mega-awesome UD-3900/HP Envy/Intel HD 4600 problem


#1

Hi - I just bought the UD-3900 to use with my HP Envy (m7-j120dx Rev 1965-110) using the Intel HD Graphics 4600. I followed the instructions to install drivers, then plug in the UD-3900. The HDMI output has worked but is intermittent and currently not working over the last 4-5 reboots and updates and changes. I have not yet seen the Ethernet work. I’ve downloaded and updated drivers for both the UD-3900 and the Intel HD 4600 and verified that I’m using USB 3.0. What am I missing?


#2

Hi Adarsh, thanks for posting! Sorry to hear of these issues you are seeing while connected to our dock and I’ll be happy to help!

Based off of your description there are a couple of different variables at play regarding your monitor and the Ethernet port. First, would you be able to let us know the status of the Ethernet lights that are on the Ethernet port for our dock? Typically you should see a solid green light and a flashing amber light.

Pending that information, we will want to reinstall the DisplayLink drivers and run the DisplayLink cleaner tool to make sure that the software is in a good state. To do so, please follow these steps ( I apologize for any redundant steps that you may have already completed ):

  1. Disconnect the dock from the system and please remove the power cable from the dock so it turns off completely. Please keep it disconnected until the last step
  2. Uninstall the DisplayLink Core software from the Control Panel -> Programs and Features. Don’t worry if this fails, just move onto the next step
  3. Download, extract and run the DisplayLink cleaner tool, found here --> http://www.displaylink.com/downloads/… and ensure it displays “Cleaning Complete” when done (video walk-through -> https://youtu.be/AcVV1gD_FvI)
  4. Once the Cleaner has been run, reboot (even if not prompted to)
  5. Now download and install the 8.0 M2 DisplayLink software, found here --> https://s3.amazonaws.com/plugable/bin…
  6. Reattach the power cable to the dock first. Once the dock is powered on, reconnect it to your system when prompted by the installer which will trigger the final portion of the installation

If these steps help, great! If not, we’ll want to examine some log files to see if they can tell us what is happening. To help us do so please download and run our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug just after the behavior has occurred and you have restarted so we can try and capture the behavior and with everything connected. Please send us the file that is created on your desktop by sending it to our direct support email at support@plugable.com with ‘Ticket Number 153709’ in the subject line so we can match everything up. We’ll examine the logs and determine next steps from there.

Thank you,

David W.
Plugable Technologies
www.plugable.com/support


#3

Hey thanks for the fast response. I’ll follow the steps and then follow up. I have previously followed these very steps (including using the cleaner) based on another post but maybe I missed something.

To answer your questions:
I do see the solid green light (and solid blue power light) but no flashing amber light.


#4

No dice. I have sent the log file to the support address.


#5

SOLVED (sorta): If nothing else, I think the instructions above made certain that I was starting again from scratch.

The solution was simple - don’t have anything plugged into the plugable docking station the first time its connected to the PC. Also, connect each device into the plugable one at a time and wait for the drivers to be installed before plugging in the next device. Once the HDMI is connected and working, I plugged in my printer, then once the drivers downloaded and installed, I plugged in my cloud drive, etc.

The only thing that does not still work is the Ethernet. Works fine plugged directly into my laptop but no lights on the ud-3900.


#6

Hi Adarsh,

Thanks for keeping this thread updated with what you had discovered. I responded in regards to the Ethernet issue you continue to see and just wanted to reply below in case you have not seen it or if the information helps other customers. Thanks!

"Hi Adarsh,

Thanks for the update. Sorry to hear that the Ethernet port is still not showing activity. If the LED lights are not lit then that usually points to one of two things, either the Ethernet port in the dock is faulty or their may be some other factor causing the connection not to work. The two most common causes are a VOIP phone between the dock and network connection causing an issue (we can remove it temporarily to test), or the dock being connected to a network device (router or switch) that only supports something called a ‘half-duplex’ connection, and our dock only supports full duplex. Half-duplex devices are pretty rare any more, but we just like to rule it out.

Assuming you don’t have a VOIP phone connected, your network device supports full-duplex and the lights on the Ethernet port of the dock are off even when a cable is connected we can assume the unit is faulty and we’ll want to move forward with sending a replacement. I will just need your Amazon Order ID number, the serial number from the bottom of the dock and your preferred shipping address to get the process started.

Thanks,

David W
Plugable Technologies"


#7