MATLAB crashing with docking station plugged in


#1

Using the most recent version of Windows 10 64-bit and DisplayLink drivers, I cannot open MATLAB with the docking station plugged in. It crashes unless I have the docking station unplugged. Any ideas on how to get around this? Thanks.


#2

This reply was created from a merged topic originally titled Project64 emulator intense lag.

Using the most recent version of Windows 10 64-bit and DisplayLink drivers, I cannot play games on the Project64 Nintendo 64 emulator unless the docking station is unplugged. Everything works fine without the docking station, but plugging it in results in intense choppy lag. Any ideas?


#3

This reply was created from a merged topic originally titled Cannot wake from keyboard or mouse.

Using the most recent version of Windows 10 64-bit and DisplayLink drivers, I cannot wake my computer by pressing a key on my keyboard or clicking my mouse. This is very inconvenient because my laptop is in a physically compact space. I believe I have all the wake settings enabled in Device Manager for these devices. This wasn’t an issue until I re-imaged my laptop. Not sure what else I can do. Any ideas? Thanks.


#4

This reply was created from a merged topic originally titled HDMI audio output not available.

Using the most recent version of Windows 10 64-bit and DisplayLink drivers, I cannot output my audio to the TV connected over HDMI. In the Sound settings, I have all disabled devices visible and there is no HDMI output available. Instead, it plays out of my computer speakers. This is not an issue when the HDMI cable is plugged directly into my computer. Any ideas?

Also, why can we not select HDMI output when there are headphones plugged into the docking station? I have external speakers plugged in, and every time I want to output audio to my TV instead I have to get up and unplug the 3.5mm cable from my docking station, which is kind of annoying. I’d rather just set HDMI as default, and then when the TV turns on, it takes over control of the audio.


#5

Hello,

Thanks for posting. Our forum moderator merged all of your separate posts together so we can keep everything in one place. You cover a lot of ground, so I will do my best address each item individually and to be succinct.

To your questions about the audio output, you want to make sure that the ‘Plugable Audio’ device is selected as the Default Playback device in Windows to enable audio to route over the HDMI output. This is different than when the monitor is directly connected to the HDMI output of your system where the monitor itself shows as an output source.

As a follow on in regard to audio, only one audio output of the dock can function at any one time. If you have a device connected to the analog audio output of the front of the dock, you will have to disconnect it to enable audio to route via the HDMI output. Both of the audio outputs are represented by the single ‘Plugable Audio’ playback device.

To your question about waking the system via USB (by using the keyboard or mouse) all of that functionality is controlled by the host system, so there really isn’t any settings to change in regard to the dock itself. Since this was working before the system was re-imaged, there may be a Windows configuration setting that still is not set right. To help point you in the right direction, you may want to check that USB Selective Suspend is Disabled as Windows may be putting USB devices to sleep and therefore not allowing them to wake the system. To do so, please follow these steps:

  1. Right-click on the Start Button and select ‘Power Options’
  2. From the window that appears, for the active power plan setting, click the ‘Change plan settings’ link
  3. From the window that appears, click on the ‘Change advanced power settings’ link
  4. From the window that appears, scroll down in the list of items and expand the ‘USB Settings’ option, and then expand the ‘USB Selective Suspend setting’
  5. Change the settings for both ‘On Battery’ and ‘Plugged in’ to Disabled
  6. Click the Apply button, and then click the OK button.
  7. Close the remaining windows and restart the system and test the behavior again.

To your question in regard to the Nintendo emulator, we don’t actually recommend our DisplayLink-based products (such as our dock) for gaming as in many cases games may try access the graphics hardware in your system directly and as such may not work as expected.

To your question regarding Matlab, while we have not tested the application with our products yours is the first such report of it not working. There may be a specific software incompatibility with this application and our dock, but our first step is to get more information from your system. If you would just after trying to launch Matlab and it not working, please keep everything connected and send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to support@plugable.com with ‘For Ticket 152922’ in the subject line. This will allow us match things up and examine some log files from your system to help determine the next steps.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#6

Thanks for the response.

-Audio output: This was fixed somehow by restarting a couple times. I had Plugable Audio set as the default already, so not sure why that was happening. Okay, I guess I’ll have to live with getting to the docking station and unplugging the cable manually.

-Wake via USB: Yeah, that was the first thing I checked, and it’s disabled. I checked all the device settings in Device Manager as well. But it looks like it’s not a docking station issue, so I’ll have to figure out if it’s some driver issue or what…

-Emulator: Okay. I’ll just unplug everything from my docking station and plug them into my laptop when I want to use programs like that.

-Matlab: Okay, I went ahead and did that. Hopefully I can start using MATLAB without unplugging the docking station.

Thanks again for the help.


#7