Laptop not recognizing the audio on my Plugable UD-3900 dock in device manager.


#1

Everything on my Plugable UD-3900 is working except the audio. In device manager I have 2 Plugable Audio, but they both have the yellow warning that the drivers are not successfully installed and the device cannot start. I’ve tried installing the Display Link software\drivers several times to no avail.

I’m running Windows 7.


#2

Hi Kerrie,

Sorry to hear about the audio driver issues. You mention installing DisplayLink software several times - if you haven’t yet run their “cleaner” tool, that’s definately a good next step. To do so:

Thanks for contacting Plugable! We’ll be happy to help.

-Disconnect the dock from the computer, and unplug the power to the dock

-Uninstall DisplayLink Core software from Control Panel->Programs. Don’t worry if this fails or if this entry is missing, just move onto the next step

-Download and run the DisplayLink cleaner tool, found here:
http://www.displaylink.com/downloads/…

-Once the Cleaner has been run, reboot (even if not prompted to)

-Now download and run the latest DisplayLink software, found here:
https://s3.amazonaws.com/plugable/bin…

-During installation, reattach the docking station (power, then USB) when prompted to connect

If there are still issues with the audio drivers after the above steps, we’ll want to take a look at some system logs. Please email support@plugable.com (subject: Ticket 134436) and we can provide instructions for collecting log files.

Thanks!
Gary


#3