Is the DC-125 USB device usable with Userful MultiSeat standalon version under UBUNTU 10.04 ?


#1

Dear Support,

I tried to use the (standalone version) with free 2 station licence
with my UBUNTU and DC-125 DockiUserful MultiSeatng Client.

The problem was that on the second station the UBUNTU’s graphics login hasn’t started instead it the remained black screen with a moveble big X mouse pointer even if I reconnected the USB cable of DC-125. (I will detail it.)

I have seen that DC-125 isn’t in the supported USB devices in Userful documents but I thought it will be usable according these 2 links :
https://www.youtube.com/watch?v=axX53S…
http://plugable.com/products/dc-125/

My experiment detailes :

My OS version:

cat /etc/issue

Ubuntu 10.04 LTS \n \l

uname -a

Linux laci-desktop 2.6.32-36-generic #79-Ubuntu SMP Tue Nov 8 22:29:53 UTC 2011 x86_64 GNU/Linux

I have downloaded the MultiSeat software from here:

Recommended Download
Userful MultiSeat v.4.0 1702 64-bit for Ubuntu 10.04
DEB | 64-bit | 14.8 MB

root@laci-desktop:/DATA/INSTALL/MultiSeat/new# ls -l u*deb
-rwxrwxrwx 1 laci laci 15568470 2011-12-16 11:27 userful-multiseat-4.0-1702-amd64.deb

and I installed it with dpkg :
#dpkg -i userful-multiseat-4.0-1702-amd64.deb

In the first install period my kernel ver was low: 2.6.32-21.
I have closed the installation and I upgraded the kernel to 2.6.32-36
After it the installation was successful, and the licence also was good for 2 station in the (Sys->Admn->UserFullCntrlcenter).

The DC-125 was connected to the PC with same LCD and USB keyboard and mouse and I did the first restarting of UBUNTU.

The MultiSeat realised the two stations, the MultiSeat logos appeared on both of terminals, and it asked me to press F1 and mouse on the station 1 (on pc)
and asked me to press F2 and mouse on the second station.

After the above on the first station (the PC) I could use the graphics login and everything looks like OK in UBUNTU.

But on the second station after pressing F2 at MultiSeat logo, X hasn’t started,
only the screen remained black with a mouse pointer (it was like a big X) and I could move it by second mouse appropriate.
So the graphics login hasn’t started on the second station.

Then I unplugged and 3 sec later I plugged again the DC-125’s USB cable. The MultSeat logo has appeared again I could press F2 again but after it
everything was same again: I had the big movable X mouse pointer on the black screen and nothing graphics login.

May be it could more info:
1/
I could change the display resolution to lower on both screen, in the (Sys->Admn->UserFullCntrlcenter) and I could see the big X mouse also (it became bigger).

2/
The first restarting was different from the others.
When the newer restarting happened with the connected DC-125, then (after the MultiSeat station checking F1 F2 …)
on the first terminal (main PC) only the ubuntu’s desktop color appeared without any menu and no login screen, only the
normal mouse on the color background. So I realized that the DC-125 needed disconnect during the ubuntu’s restarting if I want to get the login screen on the first station.

Unfortunately the second screen always was black (no any graphics) only the movable big X mouse.

I would like to ask to help or any suggestion in the above problem?

Thanks and Best Regards
Laszlo Szilagyi
frm.: Budapest HU.

ps.:
more hardware details:

The PC was : HP Compaque DC5100 (3GByte RAM/3GHzCPU )
Monitor 2X LG Flatron L1942S 1280X1024
USB mouse and keyboard on DC-125
and ps2 keyboard and mouse on the main PC.
(I attached two photo also.)
!](https://s3.amazonaws.com/satisfaction-production/s3_images/657003/1_inline.JPG)](https://s3.amazonaws.com/satisfaction-production/s3_images/657003/1.JPG) !](https://s3.amazonaws.com/satisfaction-production/s3_images/657005/2_inline.JPG)](https://s3.amazonaws.com/satisfaction-production/s3_images/657005/2.JPG)


#2

Hi Laszlo,

Thank you for all these great details! The standalone version of Userful opens up some extra things that can be different.

You’ve done a great job explaining what you’ve seen - we’ll go over the details and try to recreate with a similar machine.

In the meantime, could you say if you’ve used the full Userful Multiseat distro on the same machine, and did that work any differently?

Thanks for your patience!
Bernie


#3

Hi Bernie,

Thank you for your quick reply.

I downloaded and installed the full solution of Userful ( UML-2011-64bit-1702-2011-05-25-1331.iso ) on the same PC.
And all appearances were exactly the same with the second terminal.

Now the UBUNTU version was:

cat /etc/issue

Ubuntu 10.04.2 LTS \n \l

uname -a

Linux szlaci2 2.6.32-26-generic #48userful1 SMP Thu Dec 2 21:02:52 UTC 2010 x86_64 GNU/Linux

and I could list the device also.

lsdl

usb-0000:00:1d.7-3.4 Plugable DC-125

So there was nothing any difference with full solution install.

Thanks and Best Regards
Laci

!](https://s3.amazonaws.com/satisfaction-production/s3_images/657431/Screenshot_inline.png)](https://s3.amazonaws.com/satisfaction-production/s3_images/657431/Screenshot.png)


#4

Hi Laszlo,

We’ve set up a system here with Ubuntu 10.04.2, the DC-125 and used the recommended download you referenced above: Userful MultiSeat v.4.0 1702 64-bit for Ubuntu 10.04 | DEB | 64-bit | 14.8 MB .

It worked right away. Here’s a few thoughts to help troubleshooting ~

Our uname -a output is

Linux plugable-desktop 2.6.32-28-generic #55-Ubuntu SMP Mon Jan 10 23:42:43 UTC 2011 x86_64 GNU/Linux

Are you running from the built in graphics or an add on graphics card? You’ll have to disable the built in graphics through BIOS settings if you’ve installed a PCI graphics adapter. There’s an explanation in the user guide section on Supported Video Cards.

Our kernel is slightly different but i don’t think that should matter; especially since the first Userful screen for associating the keyboard and mouse with the display works. This fact also points at the graphics hardware working on a low level.

If that’s all in order, it must be a problem with the Userful setup. Let us know about the graphics card situation on your system and keep trying, it should work!

Thank you very much,
Happy Holidays,
Jerome.

Plugable Technologies.


#5

Hi Jerome,

Unfortunately the problem has remained unresolved.

Here is the answer for your question:
I have only built in graphics (it’s integrated on the mother board of dc5100) and no any extension on this PC box.

Here is the PCI list:

root@szlaci2:~# lspci
00:00.0 Host bridge: Intel Corporation 82915G/P/GV/GL/PL/910GL Memory Controller Hub (rev 04)
00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC’97 Audio Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) IDE Controller (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FB/FW (ICH6/ICH6W) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
40:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)

I installed the ubuntu-10.04.2-desktop-amd64.iso and I didn’t choose any update after it.
Then I installed the (standalone ver) userful-multiseat-4.0-1702-amd64.deb .
Now I have got the same Ubuntu and kernel version like you.

root@szlaci2:~# cat /etc/issue
Ubuntu 10.04.2 LTS \n \l

root@szlaci2:~# uname -a
Linux szlaci2 2.6.32-28-generic #55-Ubuntu SMP Mon Jan 10 23:42:43 UTC 2011 x86_64 GNU/Linux

In the UserfulControlCenter evrything looks like OK. I can enable and disable the second terminal.
According to its status it gives the appropriate Userful logos and asks me to confirm the keyboard and mouse.
But after the confirmation the same problem appears the black screen with X mouse and no graphics login.

I note again that the full version UML-2011-64bit-1702-2011-05-25-1331.iso had the same problem in this environment.

I can’t imagine where could be the difference.

Happy Holidays!
Best Regards,
Laszlo Szilagyi


#6

Hi Laszlo,

Can you forward your dmesg output over to support@plugable.com? We’ll take a look and see if anything looks incorrect.

Thanks,
Jerome.


#7

Hi Jerome,
Now I sent it to support@plugable.com in a zip attache.
Thanks and Best Regards
Laci


#8

Thanks Laci~


#9

Dear Jerome,

I’d like to send more info to you.

I took my newer PC:
Mother board/CPU/memory:
Gigabyte GA-870A-USB3
AMD Phenom II X2 560 Black Edition Box
Kingmax DDR3 1333MHz 16GB
Display card: Asus EAH5450 SILENT/DI/512MD2/LP - HD5450 512MB

I have managed to change the license between two PC at Userful and I installed
Ubuntu 10.04.2 and userful-multiseat-4.0-1702-amd64.deb standalone version.
I have got the same problem, so I really can’t imagine what could be the difference between my and your experiment. More over I have got another problem I couldn’t go into DisplaySetting
menu I sent a jpg of it.
And I sent also some output attached in e-mail to suppor address.
dmesg.txt lshw.txt lspci.txt ver.txt

brgds & Happy New Year /Laci


#10

Dear Jerome,
and I send these logs also to the support.

tar -tf log.tgz

userful-welcome.log
messages
kern.log
Xorg.0.log
userful-udev.log
userful-id.log
Xorg.1.log
userful-trace.log
userful.log
auth.log
userful-pfkd.log
userfulcs.log
userfulls-1.log
user.log
syslog
debug
daemon.log
root@szlaci3:/var/log#
brgds/Laci


#11