incompatible usb 2.0 memory stick using PLUGABLE 10-port 2.0 USB hub


#1

I tried to use a toshiba usb 2.0 memory stick plugged into the PLUGABLE 10-port 2.0 USB hub, and I get the message that it cannot recognize the device. It works OK with other hubs like the 7-port Belkin USB 2.0 hub or plugged directly to the computer USB. The Toshiba unit is a 16 GB memory stick and is 2 months old bought at STAPLES.

My computers are 2-descktops HP computers, a Toshiba laptop with USB 2 and USB 3 ports. My operating system is Windows 7 64 bit with all the latest updates, and the USB driver is a generic Microsoft driver. I have about 10 memory sticks of different manufacture (PNY, Sandisk, HP, Phillips, and DT101 G2) and they work perfectly well with the hub.
The hub is connected directly to the computer and uses the supplied A/C cord. I tried all the connectors on the hub without success.

Description of Toshiba memory stick:
16 GB Toshiba
C929BA0460 2GMG made in China

Computers: HP P7-1240 US with AMD A10 (USB 2.0 and 3.0)
HP 600-1120 with Intel i-3 first generation
Toshiba Satellite with Intel I7 second generation (USB 2.0 and 3.0)
HP Pavillion Laptop wth Intel I7 first generation.


#2

Hi Kenneth,

Thanks for posting your question here on our support forum, I’ll be happy to assist.
My suspicion is that the particular memory stick that’s having troubles may be drawing a bit more power than the others.

Let’s try this –

First reset the hub by disconnecting everything from it and then reconnecting. First connect the AC power, the the data cable to the computer, the try the Toshiba memory stick in one of the two flip up ports.

Does it work?

Let me know what you find and we’ll figure out our next steps.

Thanks,
Jerome.


#3