I can't get ports 1-4 working on my USB3-HUB7-81X, sn 1027002A01275

Topic says it all.

Hi Nicholas,

Thank you for your post! I’m sorry to hear you are experiencing difficulties with the USB ports on the device.

Could you please run our diagnostic program? It will gather device information and installation logs that will help me understand what happened.

To do this, please plug the adapter into your computer, then go to this page, and follow the instructions there:


When you run the program, it will create a zip file on your desktop with your computer name and the date. Please send that file directly to our support email address at support@plugable.com.

Please put “For Ticket #209525” in the subject line.


Plugable Support


This problem was solved with emails through our support@plugable.com account and a firmware update of the hub along with usage on USB 3.0 ports. The system is now recognizing all ports!

We will be closing this thread as solved and if any further support is needed please email support@plugable.com!

Thank you,

Derek Nuzum
Plugable Techonologies