High CPU Utilization - 28% by DisplayLinkUserAgent application


#1

The DisplayLinkUserAgent application is consuming about 28% of the CPU. Can you please suggest a fix.

Here is my configuration:
Microsoft Surface Pro 3
OS: Windows 10
Connected to Plugable UD-3900
1 Display Monitor - 1920 x 1080
Monitor connected in Extended Mode

Please let me know if you need any additional information.

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1350118/TaskManagerCapture_inline.PNG?1453389084)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1350118/TaskManagerCapture.PNG?1453389084)


#2

Thanks for posting. The first thing to check is if any anti-virus or anti-malware applications are scanning the DisplayLink driver files and causing the behavior. Can you exclude the files shown in my screenshot from any such utilities (such as the built-in Windows Defender or any 3rd party utility like Malware Bytes) to see if that helps change the behavior?

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1350204/Filestoexcludefromscanning_inline.JPG?1453398446)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1350204/Filestoexcludefromscanning.JPG?1453398446)

If it does, great! If not, you may be running into an issue currently being working on by DisplayLink as discussed here -> http://support.displaylink.com/forums… where DisplayLink has a development build that may fix the issue. They are asking for people to contact them directly to provide the build as it is not available for download.

Let us know if that information helps and we’ll go from there.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3