HDMI Adapter lights up but no picture!


#1

I received my new UGA-4KHDMI adapter yesterday and have not been able to get the video to show up on my external display. Please help.
The light on the device is lit and the OS10 Device Manager sees (and names) a Plugable USB display device, but no video is pushed to my monitor.
So far, I’ve tried plugging the device into different USB ports, updating the driver, rebooting the machine, switching HDMI inputs on my monitor, swapping to a different HDMI cable, and the WINDOWS-P trick in your manual. When I swapped HDMI cables, the monitor recognized that a cable had been plugged in but then said there was not signal. No matter what I do, the monitor is not seeing any incoming signal.
My monitor, btw, is an LG Ultrawide 29UM57. And my laptop is a Lenovo T450S with an onboard intel 5500 graphics card – one that sadly won’t push my external monitor’s 2560x1080 resolution. The monitor works fine with a miniDisplayPort to HDMI cable – just not at the desired resolution.
Please advise.


#2

We worked with John via our private email ticketing system to resolve this issue. Ultimately the resolution was to perform a clean installation, using the 7.9M3 version of the drivers.

Posting clean installation instructions below as a resource for any who come across this thread researching an issue in the future:

Let’s go through the clean install process again, but we’re going to try installing a previous revision of the drivers. We’ll do all of the following with the adapter disconnected until the last step.

-Disconnect the USB adapter

-Uninstall DisplayLink Core software from Control Panel->Programs. Don’t worry if this fails or if this entry is missing, just move onto the next step

-Download and run the DisplayLink cleaner tool, found here:
http://www.displaylink.com/downloads/…

-Once the Cleaner has been run, reboot (even if not prompted to)

-Now download and run the M3 version of the DisplayLink software, found here:
https://s3.amazonaws.com/plugable/bin…

-During installation, reattach the adapter when prompted to connect.


#3