GoPro Studio will not play MP4s on monitors attached to UD-3900


#1

My Plugable UD-3900 recently began to cause issues where videos such as MP4s will not play in video editing software such as Corel VideoStudio X10 and GoPro Studio. Both of these applications had been working fine for months.

For example, when I open GoPro Studio on one of the monitors attached to the Plugable, the videos will not play video or sound, however when I move the window onto my laptop they play just fine.

My laptop is a Yoga 2 Pro, Core i7-4510U @ 2Ghz, 8GB RAM, Windows 10 x64 Build 14393.0.

Again, everything had been working for months. My only guess is that a driver update screwed things up.

I even tried resetting my Windows 10 back to factory settings, e.g. resetting the machine, and saw the same behavior.

I really love the product but would like to continue editing videos on my monitors. Anything you can do to help would be great!


#2

Hi Ryan,

Thanks for posting, and I would be happy to help with your docking station!

Thank you as well for the great detail you provided that is most helpful. Based on your description, it sounds like you may be running into a known bug with the Windows Anniversary Update (build 14393). To help determine if that is the case here, we will want to do two quick tests.

  1. With the laptop lid open and the internal LCD display active, please configure the internal LCD display to be the ‘Main’ display in Windows (video walk through here if you need it -> https://youtu.be/7nnKztRZXsw) and then reboot the system and test the behavior again.

  2. If option one did not help, please disconnect the dock from the system (and keep it disconnected) and reboot. Launch either application to have it up an running. Once the app is running, reconnect the Plugable dock to the system. Once the dock and it’s displays have been recognized, please move the application window to one of the displays and test the behavior again.

Please let us know if one or both of those options helped when you have a moment, and we will determine the next steps from there.

Thank you in advance for your patience!

Bob
Plugable Technologies
www.plugable.com/support


#3

Thanks for the suggestions.

Both options behaved the same way – I was unable to play video on the monitors, but was able to play it on the laptop screen.

During my testing I also determined that audio will play in GoPro Studio on the monitors *when the laptop screen is also open*, but will stop as soon as I close laptop, turning off its screen.


#4

Hi Ryan,

Thanks for getting back. When you say, “…I also determined that audio will play in GoPro Studio on the monitors *when the laptop screen is also open*…”

By any chance did you instead mean ‘video’ where you said ‘audio’? Apologies if that is redundant, I just want to make sure I have the details correct.

Thank you,

Bob


#5

No, I meant audio. The audio will play and I can skip forward, backward, etc. in the video, but there is never any video image. I still haven’t been able to get video image to play on the monitors since the issue started happening.


#6

Hi Ryan,

Thanks for getting back, appreciate the confirmation and apologies for my misunderstanding.

I replicated the behavior you are seeing in house, and the short version is that this appears to be a combination of the Windows bug I mentioned previously and an application specific issue with the GoPro app. A workaround that worked in my test setup was to import and convert the clip(s) while using the ‘View & Trim’ tab when the GoPro application window was located on the internal laptop display. Once converted and then by switching to the ‘Edit’ tab of the application, the video played as expected when the application window was then moved back to a display connected to the dock.

If you will pardon the technical digression, the long version is that with the release of the Windows Anniversary Update (that your system is now running) Microsoft has made low-level graphics changes that can cause applications that require the use of OpenGL (which the GoPro app requires -> https://shop.gopro.com/softwareandapp… under the ‘System Requirements’ tab) not to work as expected.

To expand further, the operating system incorrectly routes OpenGL tasks meant for the for the internal graphics adapter in your system to the wrong place causing certain functions not to work. In instances where this has affected those using our products, the two methods I suggested previously (changing the ‘Main’ display or plugging in our product after the application launch) have been able to workaround this Microsoft bug and yours is the first such report we have had to the contrary.

I replicated the behavior you are seeing with one of our test systems and the UD-3900 dock, but where it got interesting (and confirms the source of the behavior is within Windows and the app itself) is when I was I able to get it to happen when no Plugable products where in use.

The laptop I tested with has two internal graphics adapters, one from Intel and one from Nvidia, in what is known as a hybrid graphics setup. Utilities from the graphics adapter manufacturer allow you to change which adapter is in use, and when I explicitly switched from the Intel adapter to the Nvidia adapter, I again replicated the same behavior you describe. The video image in the playback window while using the ‘View and Trim’ tab was blank/black, but would ‘play’ in that the time indicator would increment and I could hear the audio. Again, this was with no Plugable products in use/connected.

Searching the GoPro support forums for similar behavior turned up a few results (none using our products though) which led me to the workaround I mentioned above. While I can’t be 100% certain, the GoPro application appears to be using a different method to display the video between the two ‘View & Trim’ and ‘Edit’ tabs, accounting for the difference in behavior.

Summing up, the initial cause of the change in behavior was most likely your system updating to the Anniversary Update exposing both the Windows bug and the GoPro specific application issue. Microsoft will have to address the issue in a future update to Windows 10 and/or GoPro would have to update their application to fix the root cause, but in the interim the workaround I suggested above appears to be the only solution.

Apologies for the very long response…please let me know if the workaround I described works on your system or if you have any additional questions, and thank you again for your patience!

Bob


#7