Formatting and encrypting drive with Trucrypt.


#1

I just bought the Plugable usb 3.0 docking station from Amazon (got it today 08-31-2011). I initialized and created a volume on Windows 7 just fine and the machine sees the drive. However, I just attempted to format and encrypt the drive using Truecrypt (which I do with every new hardrive) and it made it about 10% of the way through before Truecrypt said it could no longer see the drive. I then got pop ups from Windows saying I needed to initialize the hard drive in order to use it. Why did it time out like that and is there some sort of fix? I cannot use your product if I’m unable to encrypt my hard drives.


#2

Thanks for posting - We’ll work to help.

The SATA dock works with both USB 2.0 and USB 3.0 connections back to the PC - I assume you were using USB 3.0, right?

If so, can you apply the latest firmware update for our SATA dock? Here’s how: http://plugable.com/2011/02/08/firmwa…

And then re-try that format and encryption operation with Trucrypt. Can you let us know if that helps?

Thanks!
Bernie


#3

Yes, I have a USB 3.0 port and I’m using the USB 3.0 wire and connection.

I am trying to format with Truecrypt again right now and I’m up to 27% so I’ll see if it works without any firmware updates.

On the firmware note…

I tried to check and see what version of the firmware I had using the tutorial on your website but the pictures on your website differ drastically from what I see on my computer.

I’ll attach a screenshot.

There’s no Standard Enhanced PCI to USB Host Controller option on my computer as you can see. !](https://s3.amazonaws.com/satisfaction-production/s3_images/570250/screen_shot_1_inline.PNG)](https://s3.amazonaws.com/satisfaction-production/s3_images/570250/screen_shot_1.PNG)


#4

OK. I updated the firmware. I’ll try again since the last try failed (I got to 37%).

Another issue is the hard drive is getting extremely hot. Should it get really hot?


#5

Great, thanks for letting us know. Drives can get hot to the touch (125-135 F is not unusual). It’s much more noticeable when this happens in the open bay (as opposed to inside an enclosure).

If you have a utility that can monitor SMART drive parameters (which works on USB attached drives), that’s a great way to get specific numbers, and monitor anything that’s over the drive’s spec …

Thanks again for letting us know if and to what degree the firmware update helps.

Bernie


#6

Yes, sorry, unfortunately different machines have a different topology leading to their USB 3.0 host controller(s). We put a screenshot of one particular machine, but should call out that it can look quite different, depending on what PCIe bus the USB 3.0 host controller is hung off of, etc. Thanks for pointing this out!


#7

The Truecrypt drive format and encryption worked fine this time around (after the firmware update).

Thanks.

As to the heat - thanks for letting me know. I had people tell me the drive shouldn’t go higher than 60 degrees and I was thinking F not C. So I I was concerned. But you cleared it up.


#8

One last question. When the drive was formatting it started at around 130 mb/s but this slowly diminished until it was only about 100 mb/s towards the end of the formatting.

Is that normal?


#9

Glad to have you up and running! On the format speed, I’m not sure, but there’s no reason for that to happen that relates to the dock itself.

Because a format is a long sequential write, perhaps there’s a difference depending on whether you’re formatting the inside or outside of the platters.

The benchmarking we’ve done is post-format (normal reads and writes), and on those, while there’ll always be some variation, there shouldn’t be any pattern like that.

Hope that helps. Thanks again!
Bernie


#10

I have another question. If I get another dock - how will I know which selection to make when I upgrade the firmware?


#11

Hi Don - thanks for asking. There is no unique serial number exposed for the dock itself (rather, it exposes the unique serial number of the SATA drive plugged into it, so Windows drive associations follow the drive, not the dock).

So you won’t have anything unique to go on - I would recommend plugging them in one at a time, to make sure you apply the firmware update to each.

Thanks!
Bernie


#12