Ethermet connection not working after Windwos update


#1

Maybe it is a coincidence, but since the Windows 10 Fall Creators update, and KB4041994 installed yesterday, the Ethernet connection via my UD-ULTCDL-EU no longer works. I have the continuous green light and flashing amber on the ports, so that looks OK. I’ve tried plugging in the network cable from another PC, whose Ethernet connection to my router is fine, and that made no difference. So I’m pretty sure it is not the cable or the router. The PC with the issue is an HP Spectre x360 AC003na running Windows 10 and, until today, it has been working fine with the UD-ULTCDL-EU since I got them both a couple of months ago. Does anyone have any suggestions? Thanks.


#2

The situation deteriorated seriously when i did a Windows network reset - the WiFi went too. Too cut a LONG story short, simply uninstalling my CheckPoint VPN software solved the problem and I’m now fully reconnected. Everything had been working together fine for a couple of months but I think that the Windows update and CheckPoint software didn’t get on.


#3

Hi Peter,

Thank you so much for reaching out to us, I am sorry for the delayed response from the holiday, but I am glad to hear everything is up and working!

Great job locating the troubled software, and getting everything working correctly. Please do not hesitate to reach out in the future if you have any additional questions or concerns.

Thank you for your patience,
Marc
Product Owner & Technical Support
www.plugable.com/support


#4