Drives powers down during file transfers after a few hours


#1

Plugable U3 docking station stops working after a few hours. It’s on, but file transfers just stall. I had this problem in both Windows 7 and in Ubuntu. In Windows 7, this inevitably results in a message saying the drive can’t be found and when clicking to continue or skip it still can’t find anything and trying to navigate the file structures doesn’t help.

The best workaround I could find is to use TeraCopy to handle file transfers to the drive because when this happens I can view a list of which files completed successfully so I can at least manually select which files to continue. As long as I physically turn the drive off and then back on again it works again for a few more hours. It seems to be some kind of power saving feature gone horribly wrong. I have all firmware updates applied. Hard drive in use is a Seagate Barracuda XT 4 TB. An old model which still uses 512 byte sector size. Using 2 Partitions, each Primary/Fat32 set to 1.8 GB. GPT.

As a side note, I really don’t like the Docking Station form because it lacks a fan. Maybe the design could be improved by having a cap with a fan on the top placed over it to suck air up and away with maybe a gap between the drive and base held firm by little edges. Such a form would help the drive run cooler and allow it to continue to function as a Docking Station, but could be “closed up” like a normal external hard drive for more continual use. Honestly the only reason I am using this instead of one with a fan is because so far it’s the only one that seems to properly support 512 byte drives at 4 TB. If such a product already exist, or if you have fan model that supports 512 byte drives, let me know and I will buy it.


#2

And it just happened - again - within 10 minutes of starting over after manually selecting the files to copy again! When I try to even look at the file structure when it happens the whole computer freezes up until I turn it off.


#3

Hi Elliander-

Thanks for posting with your issue! The behavior you are seeing is likely due either to:

  1. A drive that is overheating and shutting off
    or
  2. A defective U3
    there is also some chance (although remote given your observation of similar issues under Ubuntu) that
  3. USB 3.0 host controller updates for the PC could also help.

The best/easiest way to test is to see if the U3 is still detected after the drive you’re accessing “falls off.”

You should be able to see if the U3 is still listed in device manager as it is when the drive is accessible after the drive “falls off” or disappears: if so, the issue is almost certainly with the drive itself due to overheating. Many consumer drives won’t hold up to hours long transfers, as most consumer applications don’t require this level of availability. If this is the case, another drive (something like one of Western Digitals “Red” series of drives designed for RAID/DataCenter applications) is the only alternative I can recommend.

If you have any trouble verifying whether this is the case, please send a mail to support@plugable.com with a link to this thread and the ouptut from our support tool, PlugDebug, run just after the drive disappears. Instructions to download and use PlugDebug are here:
http://plugable.com/support/plugdebug

Also, to follow up on your previous ticket, the re-link section isn’t important, and this isn’t cause for concern. Please let me know of any other questions.

Best wishes-

Jeff Everett
Plugable Technologies


#4

Overheating is probably the cause. I need it to be capable of being “always on” (and I know of absolutely no consumer applications for a hard drive other than that). If your device really is incapable of staying on then why doesn’t it say so on any product pages? The longest I can apparently keep this plugged in without failure is 3 hours after being physically turned off for 12 hours. Turning it off then on gives me only 10 minutes of use unless I let it sit off for a long time.

The issue is definitely not “The Drive Itself” because it works fine in other enclosures without any of these problems. Of course, other enclosures either had a heat sink or a fan attached. The only reason I am using your system is because it is (so far) the only one I can find that will present a 512 byte sector size as having 512 bytes while also seeing the entire hard drive capacity. Advising me to get a new hard drive and blaming it on the hard drive itself is in really poor taste. Sure, it’s the hard drive that is over heating, but it is only doing so because your docking station is poorly designed. For your information, I can’t use anything newer than 2011 because I need a 512 byte sector size drive. All new hard drives use Advanced Format 4k.

The cable I am using is the USB 2.0 one with a USB 2.0 connection.

Also: This produced is advertised as supporting 4 TB hard drives. All 4 TB hard drives produce more heat than those of smaller capacities. If it is incapable of supporting the heat produced by such a drive it is incapable of properly supporting the drive.


#5

Hi Elliander-

Thanks for getting back to us. We have had no issues running drives in the U3 for extended times into the several hour range, so with the additional details requested below I’m confident we’ll be able to find a solution.

For further troubleshooting assistance, we will need the details provided by our support tool, PlugDebug. Please send a mail to support@plugable.com with a link to this thread and the ouptut from our support tool, PlugDebug, run just after the drive disappears.

Instructions to download and use PlugDebug are here:
http://plugable.com/support/plugdebug

Best wishes-

Jeff Everett
Plugable Technologies


#6

Well, turns out it’s definitely NOT from over heating. It turns out the only partition that stops working it the one being used. The other partition continues to work. So, for example, I was resizing a partition and in the middle of the operation it just stopped working. The partition manager gave me an error that it can’t find the disk and in My Computer the drive letter shows up for it, but no drive. The other drive is still there and I was able to load a file from it without any problems.

Thanks to this piece of junk though I lost an entire partition with EVERYTHING on it. I had backups, sure, but given how often this things stops working it will take me a whole WEEK to get it back onto it!

The drive isn’t too hot to touch, and I have been using it near an air conditioner just to be sure. So basically, when I use it to access files it just gives me a random hiccup and stops working until I turn it off and turn it back on.

I don’t believe your product is safe to use.

EDIT: I was able to restore that partition, but it’s still not good for a drive to cut out like that.


#7

Hi Elliander-

Could you please reply with the output from our support tool, PlugDebug. To be able to help you, we need a lot of information about your system. Without these details, there really isn’t much we can do to help.

Please let us know if you’re having any issues with using PlugDebug:
http://plugable.com/support/plugdebug

As I mentioned some time ago, there is a chance the issues you’re seeing are from a defective unit, and we’d like to be able to determine if a software fix or an exchange is more likely to help- however we need the requested details to be able to do this.

Best wishes-

Jeff


#8

I already sent it.


#9

Hi Elliander-

Thanks for submitting your PlugDebug file.

From this, I see that both the U3 and a “H” drive seem to be operating normally, so this raises 2 questions:

  1. Can you say if PlugDebug was run when the one partition was working normally and only the other partition was accessible?
  2. What drive letter is assigned to the partition you’ve had issues accessing?

I also don’t see any USB 3.0 “xHCI” host controller on the system. We’ve often found that updating USB 3.0 host controller drivers helped in similar cases, so we’d verify that you’re connecting to USB 2.0 ports and be certain we’re not overlooking a needed driver update.

Please let me know on these 3 details and I can recommend our next steps:

  1. Was plugdebug run when one partition worked but the other didnt?
  2. What drive letter is assigned to the partition that you’ve had issues with?
  3. Does your system have USB 3.0 ports?

Best wishes-

Jeff


#10