drivers for a plubagle usb 2.0 10-hub


#1

I have a plugable usb 2.0 10-port hub. I am running Windows XP on a Sony vgn-c190G laptop. A message started poping up that the hub is not reconnized and it needs drivers that it can not find. Could you send me drivers or direct me where I can down load drivers.


#2

Hi Paul,

Thanks for posting our question here! Standard USB 2.0 Hubs like our Plugable USB 2.0 Hub does not need any third party drivers as the hub drivers are integrated in the operating system.

At a high level, this hub is matched to the proper drivers in \windows\inf\usb.inf and the main driver loaded to control the hub is \windows\system32\drivers\usbhub.sys.Both of these are Microsoft-provided system files.

The first thing to check when Windows is showing an error saying that the drivers are missing is whether these two files are present. If these files are present, then do check that the dates are not older than 2008.

The easiest way to fix the issue is to copy these files from another system running Windows XP to the right directory in this system.

Here is a link to another post with the same issue: http://support.plugable.com/plugable/…

In both cases given on the thread, copying the usb.inf file to c:\windows\inf\ fixed the issue.

If you continue to see the issue after ensuring that these files are present on the system, just email us a screenshot of the ‘Device Manager’ at support@plugable.com along with your Amazon Order ID and a link to this thread and we will take care of the issue.

Regards,
Roze


#3