Device not recognised?


#1

I have a problem with my Plugable Superspeed USB 3.0 Hub.

I Initially used it on my standard desktop machine without issue.

However, I recently (Feb 2014) built myself a Gaming PC using an Asus Maximus VI Hero Z87 Motherboard, which uses an Intel® USB 3.0 eXtensible Host Controller: v2.5.0.19, which is the latest version.

Firstly, the hub is not recognised by Windows as a USB3 hub, and initially installs it as a USB2, despite being plugged into one of the 4 USB 3 ports on the rear of the motherboard, it then displays the message ‘your device is ready to use’. I have tried using each one of the four USB 3 ports on the rear without it being recognised as USB3.

Then, after a while the hub disconnects itself from the system with the usual audio beep, and then re-connects just as quickly. However after this the hub is shown as an ‘unknown device’ in Device Manager (see below)and there is a pop up message ‘USB Device not recognised’ from the taskbar.

It then over time continues to disconnect and re-connect at random with the windows error message ‘Unknown Device’ popping up from time to time, but not every time.

When I ran the Plugable VL-812v8581 USB 3.0 hub update utility, it stopped prematurely with a ‘no device found’ error.

Any suggestions?

Gary

!](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1047534/PlugableHuberror_inline.jpg?1397861004)](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1047534/PlugableHuberror.jpg?1397861004)


#2

Hi Gary-

Thanks for posting with your issue, sorry to hear about the trouble with the hub- I’ll be happy to help.

There are a couple of quick software-level things I want to check (it doesn’t make sense that the hub is faulty if it worked with the old PC), but if we find evidence that the hub needs to be replaced it’ll be no problem to try a pre-tested replacement unit.

One reason we’ve seen hubs connect as USB 2.0 instead of 3.0 is if the USB 3.0 cable is very long, or faulty. USB extension cables tend to be problematic. Can you say if you’re using the USB 3.0 cable that was supplied with the hub, or is it connecting through anything else?

Intel’s latest/recommended driver for their new “8” series USB 3.0 chip, 2.5.3.34, is available at the link below. It was just released this last February (yours shows as being released 29/03/2013, almost a year before). I can’t say for certain if it will help but I did want to let you know that there seems to be a newer version, so trying this might also be a good idea:
https://downloadcenter.intel.com/Deta…

Please let us know of any other questions or how it goes after the driver update.

Best wishes-

Jeff Everett
Plugable Technologies


#3