Device no longer working through 10 port usb hub.


#1

Okay, I have two Plugable USB 2.0 10 port hubs. I have a device that I have used exclusively through one of the hubs. It has now stopped working. I have connected it to the other hub, it does not work on it either. If I plug the device in to one of the ports on my computer it works. The device is self powered, and I receive a communications error trying to access the device. When I plug the device in through the hub, I see it appear in the correct Com port. I have reinstalled the device driver. Still not working. I am assuming this is a driver issue, but you do not have a driver for this hub. I have installed another device since last time that this device worked. I have uninstalled its driver, with no change. Do you have any suggestions?


#2

Hi Scott,

Thank you for posting about your 10-port hub.

There could be several things that could cause this problem. You are right, it could be a driver issue, but the hub drivers are built into the Windows system, so if there is a corrupted hub driver, we would renew it through Windows.

There are other possibilities. For example, if you are using the same power supply on both hubs, it could be a power supply issue.

The best way to find out is to get a snapshot of what is happening in your system. We have a tool that helps us do that. Please plug the hub into the computer, and plug your device into the hub. Then please go to this page and follow the instructions there:

http://plugable.com/support/plugdebug

This will create a zip file. Please send this directly to our support email at support@plugable.com instead of posting it here.

Also, please tell me the make and model of the device you are trying to connect. That may give some clues to the hub’s behavior.

David
Plugable Support


#3

Thank you, David. I will do it this evening, and send you the results. I suspect it is a driver issue. The power supplies are different.


#4

Thank you!

Could do one more thing for me? Please verify that both power supplies are 5 volt supplies. Unfortunately, there is no standard for tip size in relation to voltage and we’ve sometimes seen situations (even in our office!) where the wrong voltage was connected.

Thanks!
David


#5

I ran the debug app and have sent the zip file to you. Both power supplies are the 5 volt supplies sent with the hubs.


#6

Hi Scott.

We have received the zip file. I’ll examine it now, and let you know what I discover.

David


#7

David, I have resolved the issue, the USB router software for the MicroHam CW device caused the issue. I uninstalled it. The SCS Tracker still did not work through the hub. I updated the driver for the tracker it began working. I then reinstalled the MicroHam software. The SCS Tracker was broken again. I then uninstalled the SCS Tracker, and let it install again, and updated the driver installed. It worked again. I verified the MicroHam device works properly and the SCS Tracker works again. It still makes no sense to me that it would work locally attached to the computer and not through the hub…unless the USB router software of the MicroHam Device, and remapped some of the USB addressing? Anyway, thanks for the help!!


#8