CONNECTING A UPS TO A PC


#1

Hi
I have recently purchased a Plugable usb serial converter, because i want to connect a UPS (uninterruptible power supply) that i have (the brand name is Riello) to my laptop, (IBM Thinkpad T-42), that does not have a serial port.
The UPS has a serial port, and i have already checked that it works on another computer that has a serial port.
I have installed the drivers on my laptop, and when i connect the converter to a usb port, it recognizes it. However, when i run the UPS program it still cannot communicate to the UPS for some reason.
Any ideas?
Thanks
John


#2

Hi John!

Thanks for posting and sorry to hear you’re having trouble with our Plugable USB Serial Converter!

We’ll get you up and running!

Can you say a little more about your setup?
* What version of Windows are you running?
* What is the UPS program called?

* Is there an option anywhere in the UPS program of what COM port to use?

The most common problem we’re seeing with those adapters is that Windows assigns a COM port to them that is too high for most older applications (most commonly COM ports would be in the range from 1 to 4 but we find Windows to assign as high as 9) - if that is the case the solution is simple - have a look at our step-by-step guide here on how to change the COM port assignment on Windows (applies to all versions of Windows).

As soon as we have this information we can suggest next steps!

Regards,
Lampros


#3

It works ! - Hi Lampros and thanks for your reply,

I changed the port COM number to a lowest number according to your step-by-step guide above and now it works fine !

Thanks very much for the fast response and the helpful advice !

John


#4

Hi John!

Glad to be of assistance !

Please let us know if you have any other questions, we’re always here to help!

Regards,
Lampros


#5

Hi

I have encountered another problem again.

  • My plugable usb-serial converter was working fine.
  • Two days ago i had to relocate my computer so i unplugged all the usb cables from it in order to move it.
  • When i finally set it up to its new location and connected the usb cables to the hub, the usb-serial converter did no recognize the serial device that i am connecting to the laptop.
  • I tried changing the COM ports from the device manager but still no success.
  • All the equiipment specifications are as mentioned in the begining of this thread.
  • Initially the usb-serial converter was connected to my laptop through a usb hub and was working absolutely fine, so i dont think the hub is the problem.
  • I think the problem must be something with software, like windows is not assigning the correct ports or something like that.

Any suggestions?
Thanks.


#6

Hi John,

Thanks for posting. When a USB device with no other unique identifiers is moved to a new port, Windows sees it as a new instance and may create a new COM port (assigning the next number).

So I think you’re on the right track with software and adjusting the COM port number. Are you able to adjust the COM port from within the UPS software? If so, I’d recommend trying to restore the COM port number to what Windows set it to, and adjust within the UPS software instead.

Also, take care if any baud, etc.parameters needed to be configured the first time, that those are done again now.

Thanks for letting us know how it goes,
Bernie


#7

Hi Bernie, - it works perefectly ok now - thanks for your suggestion,

I did as you said, i restored the COM port from within the UPS software to what Windows set it to and now it works all right again like it did before!

Thanks a lot for your advice!

John


#8