Communicator U3 Not Working


#1

I ordered the communicator U3 from Amazon…order number 107-9254328-5523429. Serial number on the device in 8477002501539. Unit will not power up with drive installed. Please help.

Derek


#2

Hi Derek,

Thanks for posting here, we’ll be happy to help. We have a troubleshooting guide available at the link below that outlines the first steps to take to determine what’s happening when something isn’t working correctly with your U3. Please take a moment to run through it and let us know what you find.

http://plugable.com/2012/08/20/troubl…

In your reply, some extra detail about what operating system you are running, whether the light on the dock is on and what’s happening at the OS level will help us determine the next steps.

Thanks,
Jerome.

Plugable Technologies


#3

Jerome,

I followed the steps in the link…still nothing.

I am running OS X 10.8.2. The light on the dock is on without the drive inserted. Once I put the drive in the dock and power on, there is no light. The computer does not recognize the dock with or without the drive in place. Please help.

Derek Naas


#4

Hi Derek,

Thanks for extra details. The dock won’t show up in Finder until a drive is installed, so that’s normal however the only cases where I’ve seen the light goes out when the drive is installed is when there’s a problem with the drive.

A few more question I have that will help narrow it down are –

Can you say which Mac you have (model and year)?
Are you getting the same result with the USB 2.0 cable as the USB 3.0 cable?
Is it possible to use a different SATA drive?

Let me know these details and we’ll figure out the best next steps.

Thanks,
Jerome.


#5