Can't repair HD as seen by SATA docking station


#1

Just got my SATA docking station from Amazon today. Hooked it up to my MacBook Pro (running OS 10.5.8) via the included USB 2.0 cable. The hard drive (HD) is visible on the desktop, and I can see all the files. However, I bought this unit with the idea being able to run Disk Utility on the HD. But, Disk Utility’s buttons for Repair Permissions and Repair Disk are grayed out. Other drives that I have hooked up via firewire cable can have their permissions repaired or the disk repaired by Disk Utility. I also tried to run another program called Disk Warrior (to repair the HD’s directory), but Disk Warrior fails to complete. I ran it several times. Are these problems just inherent with the docking station? Please advise.

Steve
Seattle, Washington


#2

Hi Steve,

Thanks for posting! That’s interesting that the files are visible there in Mac OS X, but the disk utilities are not wanting to access the drive.

Quick question: I assume since you’re wanting to run the disk utilities, you must have seen a problem with this drive before? If so, can you describe what errors you’ve seen in the past when this SATA drive was connected via the other mechanism? Or are you just trying to reformat?

Also, the most common source of this problem seems to be when some files on the drive are in use by the Mac OS X operating system itself. But if you’re connecting the drive after Mac OS X boots, this shouldn’t be the case.

We’re also doing some tests here to see if we can recreate this particular problem, since we haven’t had a report of this before.

There should be a limited number of reasons why the drive would be accessible at a file level, but not by lower level utilities - I’m hopeful we’ll find a solution.

Thanks for your patience!
Bernie


#3

Thanks for your reply. No, I had not seen any specific problems with this drive when it was used as my boot up drive in an iMac G5. Running Disk Utility and Disk Warrior on it was more like checking out the drive’s general health before I put it into another iMac. I’ll await the results of your tests.
-Steve


#4

Hi Steve - Just an update that we can recreate what you’re seeing. It’s with a drive that’s fine, all normal file accesses are fine, but Verify/Repair is greyed out in the Mac Disk Utility. We’ll have to dig into this further to identify the reason why, and if it’s common to USB Mass Storage or not (since we’re using Apple’s own drivers), and if not what the device could do differently. Thanks for your patience while we look into this, but until then, there should be no problem accessing the drive. Thanks! Bernie


#5

Bernie-
While you’re working on this, here is one more piece of information for you. I pulled out my working boot-up drive from my second iMac (I have two) and tried this drive in the docking station (which was connected to my laptop). I had the same problem with it. Verify/Repair is greyed out in Disk Utility. Also, I got a message on the screen to the effect that the drive was “non-repairable” and I needed to reformat it. That’s a scary message, but I don’t believe it because the drive was just fine while it was in the iMac just moments before. I forgot to mention that I got this same message when the docking station had the first drive I wrote you about. I have attached a screen shot (as a PNG file) I took of the message, in case it’s of any use. (I have now returned the hard drive to the second iMac, and it’s working perfectly.) !](https://sslproxy.getsatisfaction.com/sslproxy/SWhAdDNLMG5zdGFuVGlWenmLbJDGd3CABhjZermgcystANA4T6nd0pzV0fSzBRRGOd17A4b8ZLwi6-HESbXI0kL6a3AwDIt6k94CY_P7YzYskhTwdmyOmX-L878ozb7io_UPlAdEw3_vWUtECJppyg==.png)](http://s3.amazonaws.com/satisfaction-production/s3_images/449873/AlertMessage.png)-Steve


#6

Hi Steve,

That is a scary message, especially since the drive is working fine via the docking station! We didn’t see this message - were there any special steps to get Mac OS X to display that message. We’re also on 10.6.6, so there’s some version differences between your setup and ours.


#7