Cannot see USB 2.0 UGA multi Display Adapters/Second Monitor


#1

Hi, bought 5 USB 2.0 UGA multi display adapters. First 2 installed seamlessly and work great. 3rd unit installs the software just fine but then their is no indication that it is installed at all. The green light on the unit is ‘off’. I cannot see the second monitor in the display settings. The PC is ZT Desktop AMD Phenom II Quad-Core Processor 955 3.2GHz (64 bit) running Windows 7 Home Edition. The video card is NVIDIA GeForce 7025. The computer is brand new and clean. Any ideas why I can’t see the unit? Should the green light be lit as soon as it is plugged into the USB port? I have installed the latest INVIDIA drivers but to no avail. Any advice would be appreciated.
Thanks,
John


#2

Solved the problem. A new driver download from the plugable site fixed the issue.


#3

Hi John!

Thanks for posting and sorry to hear you’ve been having problems with our Display Adapters! We’ll get you up and running!

Just to check: are those the UGA-2K-A you’re having problems with?

The green light doesn’t come on until the drivers are installed and Windows have enumerated the device. Since you are running more than 2 of our UGA adapters on the same computer, we recommend trying the latest DisplayLink drivers - they can be downloaded here. If the green light still doesn’t come on after the driver is installed, it probably means you have a bad unit.

Please try the new driver and let us know how it goes and what error messages you’re seeing!

Regards,
Lampros


#4