Bluetooth USB Adapter (USB-BT4LE) Ubuntu 12.04 Telephony Duplex (HSP/HFP)


#1

I recently purchased 2 USB-BT4LE Bluetooth Dongles. I am having trouble getting them to work in Ubuntu 12.04. The kernel version I’m using is: 3.8.0-34-generic.

I am unable to get my headset to work in Telephony Duplex (HSP/HFP). A2DP seems to function correctly. I tried using an older Bluetooth 2.1 dongle and the headset functions just fine in both modes. I believe I am experiencing something similar to:

http://askubuntu.com/questions/180437…

A fix seems to have been added to Ubuntu based on a link found in the answers for the above topic. The link bellow (near the bottom of the comments – edit: Comment #11) says “To test this, you’ll need a firmware image for your module. It must be in hcd format.”

https://bugs.launchpad.net/ubuntu/+so…

Is this process still required? Will adding the firmware file solve this problem? And if so, where can I get the firmware that I need?

In support topic:

http://support.plugable.com/plugable/…

Your representative says that you specifically support kernel versions 3.2.20 and 3.4. Your product page says “Linux kernels after June 2012 or so have support for this adapter.” I am reasonably certain 3.8 came out after June 2012.


#2