ASIX driver installer for Mac broken


#1

Your latest ASIX 88178 drivers for Mac OS X (release date Feb 2011, internal file timestamps Dec 2010) have a broken installer.

You need to chmod 755 the preflight and postflight scripts. Then it works.


#2

Hi Bob,

Thanks so much for this report, and how you worked around it! We’ll repro here, and then get in touch with ASIX to get a permanent solution in place (either require elevation, or fix the permissions), and get their packages for the AX88178 updated to reflect that.

Our apologies!
Bernie


#3

Apparently they use Textpad to edit the files in-place and that’s probably how the perms got broken. Bad bad bad.


#4

Hi Bob,

With a first attempt, we were unable to reproduce this problem on a Mac OS X 10.6.6 system here. This is with the latest ASIX Mac driver http://www.asix.com.tw/FrootAttach/dr…

Can you say a bit more about your Mac (running 10.6.6?), and what behavior/messages you saw when you ran the installer in the failure case?

Thanks for sticking with this so we understand the problem fully!
Bernie


#5

The .pkg file is within a .zip. I used the command line unzip utility. By redoing this with the “double click from Finder” method to extract it, the permissions were all executable and it works.

I’d suggest moving to a proper .dmg installer like other software since it preserves permissions no matter what. Zip utilities vary in how they set perms on extracted files and the file format doesn’t provide a permissions field.

Feel free to mark this solved but maybe room for improvement.


#6

Ah, great! Makes sense - and that’s a great suggestion to make it less failure prone.

Until then, we’ll try to make sure people are sticking with Mac’s own folder unzip facility, since we know that persists permissions as expected.

Thanks for highlighting this issue! Glad it’s understood.

Bernie


#7

Just a quick note that we gave this feedback about moving to a .dmg to ASIX. They had already been working on it.

And now their latest gigabit driver package has been upgraded to use a .dmg style installer: http://www.asix.com.tw/download.php?s…

So the feedback hopefully helped push things along. Thank you!
Bernie


#8