Antique, 9 pin, serial trackball


#1

I have an old trackball, purchased in the late '80s/early '90s when I upgraded to a a 486. It (the trackball) was quite expensive at the time (about £18.00 - or maybe even £30.00 - if I remember aright). It was unbranded and ran on a fairly basic DOS driver BUT it was the BEST, easiest & most reliable pointing device I ever used - and I used it for about 12 years or more (DOS, Desqview, OS/2 & Linux) until serial became old hat.

Now I use a laptop running Linux. I have read good reviews about the Plugable USB to RS-232 DB9 Serial Adapter (Prolific PL2303HX Chipset). I have plugged it into my Linux (i5) Laptop and attached the old Trackball. The system recognizes it - Bus 002 Device 006: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port - BUT it doesn’t seem to recognize any signal from the Trackball.

I have read the post @:

http://support.plugable.com/plugable/…

and think that I’m on “a hiding to nothing” - unless you know more about it than in the that post, posted “over 3 years ago”.

You ask for my Amazon order number: Order #026-7216310-9610720


#2

Hello Duncan,

Thank you for being a loyal customer and for coming to us with your concerns. I am very sorry to hear this!

It would be really handy to find out what brand and model the trackball mouse is for tracking down a kernel module just in case it is not included in the current kernel.

The only other trick I know is to add your non root user to the “dialout” group, sometimes that helps (for further explanation please see -> http://askubuntu.com/questions/133235…). I hope this information helps.

Kind regards,
Patric
Plugable Technologies


#3

[quote]My guess is the adapter and the mouse are both working fine, the problem is your OS doesn’t know that what you just attached there is a mouse. The device is probably popping up at /dev/ttyUSB0 (typical for USB/serial adapters), which means you just need to tell your OS to use that device as the mouse. I’m not sure how to do that, but I imagine it should be easy enough to figure out. When you get it working, you may consider putting in a udev rule for it to make sure that hot-plug name changes don’t mess you up.

This may help:
https://help.ubuntu.com/community/Ser…

What distro are you using?
Last edited by suicidaleggroll; Yesterday at 23:36.

[/quote]

I would guess that I have to edit (or create) a file like one of these.

[/quote]


#4

Hi Duncan,

To be honest, it has been an eternity since I have dealt with SuSE but I found this thread here that might be able to get you on the right track by automating the functionality of the trackball mouse -> http://forums.opensuse.org/showthread….

Kind regards,
Patric
Plugable Technologies


#5

Patric - I’m sorry I didn’t find this earlier but, meanwhile, here’s where I’ve got to so far:

To begin with, it is probably worth saying that the Quick Introduction Guide to this product says that

Quote:
“Linux opensource drivers are included in Linux kernels 2.6.11 & later. They support the Prolific 2303 & recognize the Plugable adapter”

First, I had been asked by Plugable for the manufacturer of my trackball (mouse). It is wholly unbranded but, by the magic of never throwing anything away, I was able to find the original manual which tells me that the Model. No: is 3000 & that it can be run in either 2 button “Microsoft” or 3 button “PC Mouse” mode.

  1. went into YaST, searched on ‘mouse’ & found I had:

Quote:
xf86-input-mouse Mouse input driver for the Xorg X server |

installed which is described thus:

Quote:
mouse is an Xorg input driver for mice. The driver supports most available mouse types and interfaces, though the level of support for types of mice depends on the OS.

  1. Hunting for something on my system the only xf86-input-mouse files I could find were in /usr/share/doc/packages/ and the only useful one was xf86-input-mouse/README and this has a whole section (Ln 403 to the end) covering the Serial mouse. Both the Microsoft & the PC Mouse are supported:

Quote:
3. 3-button serial mice may work with the “Mousesystems”
protocol. If it doesn’t, it may work instead with the
“Microsoft” protocol although the third (middle) button won’t
function. 3-button serial mice may also work with the
“Mouseman” protocol under which the third button may function
as expected.

  1. 3-button serial mice may have a small switch at the bottom of
    the mouse to choose between ‘‘MS’’ and ‘‘PC’’, or ‘‘2’’ and
    ‘‘3’’. ‘‘MS’’ or ‘‘2’’ usually mean the “Microsoft”
    protocol. ‘‘PC’’ or ‘‘3’’ will choose the “MouseSystems”
    protocol.
  1. A Global Moderator from SuSE (Deano_ferrari) suggested that I could create a .conf file in /etc/X11/xorg.conf.d/, and add the required configuration there. He pointed me to man xorg.conf.d.

Finally, I ran ls /dev > dev-out.txt with the extension not plugged in & ls /dev > dev-in.txt with it plugged in. I then ran:

Quote:
Bash - 4.2.45 : diff dev-out.txt dev-in.txt
> serial/
> ttyUSB0at

and here is the file ‘TrackBall.conf’ up with which I came:

Quote:
Section “InputDevice”
Identifier “TrackBall”
Driver “Microsoft”
Option “Floating” “true”
Option “Device” “/dev/ttyUSB0”
#Bus 002 Device 004: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
Option “Protocol” “auto”
Option “ZAxisMapping” “4 5”
EndSection

However, this doesnt work.

I may be wrong but there are 3 .conf files which I suspect are causing the problem:

/etc/X11/xorg.conf.d/10-evdev.conf
Quote:
7 Section “InputClass”
8 Identifier “evdev pointer catchall”
9 MatchIsPointer “on”
10 MatchDevicePath “/dev/input/event*”
11 Driver “evdev”
12 EndSection

21 Section “InputClass”
22 Identifier “evdev touchpad catchall”
23 MatchIsTouchpad “on”
24 MatchDevicePath “/dev/input/event*”
25 Driver “evdev”
26 EndSection

and (particularly):

/etc/X11/xorg.conf.d/11-evdev.conf
Quote:
Section “InputClass”

Novell Bugs #597214, #780626, #843333

Identifier “IBM TPPS/2 TrackPoint|ThinkPad USB Keyboard with
TrackPoint”
MatchProhduct “TPPS/2 IBM TrackPoint”
MatchIsPointer “on”
Driver “evdev”
Option “EmulateWheel” “on”
Option “EmulateWheelButton” “2”
EndSection

but also:

/etc/X11/xorg.conf.d/50-synaptics.conf

I’m sure the answer is (relatively) simple but I’m completely stuck. Am I nowhere but somewhere - or, in the words of Jeff Beck - “Everywhere but nowhere”? (although I would never have worn a hippy hat; I always prided myself on being the last of the Beat Generation)

(and if you want a blow by blow account, these may be the places:

ions/showthread.php?p=5211004#post5211004
showthread.php/499840-Antique-9-pin-serial-trackball-thru-Plugable-USB-to-RS-232-DB9-Serial-Adapter?p=2656351#post2656351


#6

Hello Duncan,

At this point I would like to slow things down and first see if the serial trackball mouse worked when you used the -> sudo inputattach --microsoft /dev/ttyS0 command. Can you please verify this for me?

Kind regards,
Patric
Plugable Technologies


#7

Whoopee - we have movement! I have no idea how this happened, couldn’t get anything out of it yesterday (despite several reboots), opened it this morning, loaded Firefox using the trackpad & opened Konsole (ditto).

Ran:

Quote:
Bash - 4.2.45 : stty -a < /dev/ttyUSB0
bash: /dev/ttyUSB0: No such file or directory
Plugged USB in:

Quote:
Bash - 4.2.45 : stty -a < /dev/ttyUSB0
speed 9600 baud; rows 0; columns 0; line = 0;
Then:

Quote:
Bash - 4.2.45 : sudo inputattach --microsoft /dev/ttyUSB0
root’s password:
And off we go. OK, the trackball, at the moment, is only moving the cursor horizontally (not vertically) but it is moving & both the L & R buttons seem to be working - I can cut & paste (I can cut & paste) using them.

Chuffed as nuts. Obviously the trackball, unused for 12 Yrs. or more, is OK. Now, all I have to do is sort out the horizontal side of things and disable the trackpad - at the moment, however, the two are co-existing.

dmk

Thanks Patric.

Looking good(ish) - but I doubt this is the last you’ll hear from me!
__________


#8

Duncan,

Patric is out today, but I wanted to give you a little more information to play around with this weekend.

Here’s a page from the Arch Linux wiki(although the information is largely relevant to all Linux distros) that lists all of the available modes for the inputattach command: https://wiki.archlinux.org/index.php/…

Of particular interest are the --mshack, --mouseman, and --intellimouse switches which could potentially resolve your issue with moving your mouse vertically, if they happen to match the signaling used on your unbranded trackball

Give those a try and let me know if they get your mouse going in 2 dimensions!

Sincerely,
Ivan
Plugable Technologies


#9