Another U3 dock fail


#1

Can’t see the dock either via USB3 or USB2 connection. Initially recognized ,then a bunch of weird error messages (AutoPlay and Format needed) and then nothing. Drive not seen in Device Manager. Firmware update fails.

Details:
Just got the dock and connected it to the USB3 port, power cable connected. (Using a new ASUS laptop with Intel i5 2.3 GHz with 6 GB RAM, Windows 7). After some hesitation Windows installed the dock and recognized the drive. (The drive is a WD 2 TB I had used in a previous Vista system, 6 months old. It has no files on it but 2 partitions.)

I wanted to make sure the drive was in good shape so I ran Windows Error Checking. Passed on 1st partition (.5 TB), although near the end of the error checking I kept getting AutoPlay notices as though the drive had just been plugged in a few times.

Then I ran Error Checking on 2nd partition (1.5 TB) and went for a walk. When I came back there were many many (maybe 20) error notices that the drive had to be formatted (each partition was named separately).

I looked on your site and tried the firmware update (http://plugable.com/2011/02/08/firmwa…). First I tried to check the existing firmware, but it does not appear in Device Manager so I couldn’t see what Firmware version it has on it. The firmware update.bat file could not even see the drive, either via USB3 or USB 2. Update failed.

Is the unit bad or what?


#2