After updating to V7.9 M5, my UD3900 won't display the correct resolution


#1

Every time I started my computer, I got no display so I had to restart again. This is standard practice as it always takes two restarts to get the monitor hooked to the UD3900 to display. I saw there were new drivers and I updated to them. Now that I have, I cannot get the previously working resolution to show anymore. My resolution should be 2560x1080 as I have an ultrawide monitor. The max it will let me use is 2048x1152. I cannot find a way to force a higher resolution. I need some help or at the very least a link to the older drivers as I cannot find them on the site.

Thanks,

Jason


#2

Hi Jason,

Thanks for posting. I’m sorry the your monitor stopped working at the higher resolution once the DisplayLink driver was updated, and I would be happy to help.

Quick thing to double-check, you only have the single ultrawide monitor connected to the dock, correct? While the HDMI output can support 2560x1080, it can only do so when it is the only output in use.

DisplayLink has historical versions of the DisplayLink driver listed here (scroll down a bit to see them) -> http://www.displaylink.com/downloads/…

If reverting to a previous version helps, great! If not, please keep everything connected and send the output of our diagnostic utility PlugDebug --> http://plugable.com/support/plugdebug to us directly at support@plugable.com with ‘Ticket 136913’ in the subject line as this will allow us to examine some log files from your system to help determine the next steps.

Thank you,

Bob
Plugable Technologies
www.plugable.com/support


#3