Help get this topic noticed by sharing it on Twitter, Facebook, or email.

Problems with 7 port USB 3.0 Hub

I received my hub yesterday and have been experiencing the following problems since the inital hookup. I have a 2012 15" non retina Macbook Pro running OSX 10.8.2 and Windows 7 in boot camp. I have 3 hard drives connected to the hub using SATA to USB 3.0 external enclosures.

1) When booting into OSX, the first thing I noticed was that the time to boot has now increased from 20 seconds to 3 to 4 minutes. It's as if the computer is having a hard time recognizing what is hooked up to it. Disconnect the hub and the boot time goes back to 20 seconds.

2) OSX does not recognize the hub by default and when it does it is inconsistent. After booting up, the computer does not appear to know that there is a USB 3.0 hub connected. In the listing under USB devices the hub does not appear, however one or more of the drives may appear in Finder. I've found that if I disconnect and reconnect the power to the hub while in OSX the USB listing will then show the device as a "USB 3.0 hub" (however this is not guaranteed). If I reboot into OSX and check the USB device listing again, it may or may not display the hub properly.

3) The computer will absolutely not boot into Windows 7 with the hub connected. Disconnect the hub and Windows boots up fine. Reconnect the hub after booting up and device manager displays two new entries for "USB 2.0 hub" but no listing of a USB 3.0 hub.

4) Sometimes one or more of the hard drives connected to the hub do not show up in Finder or Explorer whether the computer recognizes the hub ot not. Sometimes disconnecting and reconnecting the drive will cause it to appear.

Needless to say the increased boot times, lack of hub recognition to assure USB 3.0 speeds, and inconsistency of hard drive recognition is a "show stopper" with repect to being able to utilize this hub. Hopefully you can provide some guidance on how to remedy these problems so that I do not have to return the hub, which is the next step.
1 person has
this problem
+1
Reply
  • Hi Dwayne-

    Thanks for posting with your findings!

    I'm sorry to hear about the issues you're seeing with our USB 3 hub on your Mac, however please be advised of the warning we've placed on our sales listing: "Not recommended on Mac because of power issues."

    While I'm more than happy to work with you to resolve any issues that we can, please understand that USB 3 support is still evolving on OS X and that troubleshooting may be time consuming and we may not be able to resolve all issues you're seeing. If you prefer to simply return the unit, please do so via the link below. Using a return code of defective will prevent your being charged any shipping fees:
    http://amazon.com/returns

    If you prefer to dive in and troubleshoot your specific issues, please let me know and I'll be happy to proceed with troubleshooting. If you can also apply any system updates available from the app store, this will also be helpful. We have been seeing several updates affecting USB 3 reliability specific to certain models of Apple computers, so applying any available updates for your system is a great place to start, and something that will be necessary to ensure the best results and simplify troubleshooting.

    Best wishes-

    Jeff Everett
    MCITP Enterprise Support Technician
    Plugable Technologies
  • (some HTML allowed)
    How does this make you feel?
    Add Image
    I'm

    e.g. indifferent, undecided, unconcerned happy, confident, thankful, excited kidding, amused, unsure, silly sad, anxious, confused, frustrated